4.1 layout does not switch

Hello, I have a problem with switching keyboard layouts in Qubes 4.1 beta latest version.
I use i3wm, but in Xfce the layout also does not switch, except for dom0, the switch works in it.
During installation, I chose both English and Russian.
I tried everything, I added “setxkbmap -model pc105 -layout us, ru -option grp: alt_shift_toggle, grp_led” in i3 config, I added “Section” InputClass "
Identifier “keyboard defaults”
MatchIsKeyboard “on”
Option “XkbModel” “pc105”
Option “XkbLayout” “us, ru”
Option “XkbVariant” “”
Option “XKbOptions” “grp: alt_shift_toggle”
EndSection
"in /etc/X11/xorg.conf.d/50-keyboard.conf, dom0 has this file by default with the same settings.
I don’t think of any possible solutions anymore.
Thank you in advance for your help.

help me please :worried:

Surprisingly, I have exactly the same problem on my workstation “MS-7A15 1.0”
Has no one faced such a problem?

AFAIK, during the installation, you can test how your languages switch works in the UI. Does it work in your case? Also, does it work in 4.0?

1 Like

I solved the problem, thanks a lot.
When installing Qubes 4.1, I chose “Alt + Shift” to switch the layout, after installation, the layout switching worked for me, I tried to change the key combination and nothing came of it, there must be a bug in changing the key combination.
At 4.0.4 everything worked fine.
Thanks.

1 Like