4.1.2 testing upgrading issue (I wish to confirm)

I’ve issues with upgrading via whonix VM. Looks like feature is broken.
I’ve seen a post that upgrades via tor are broken due to tor gets looped kinda “connecting, we recommend to wait” forever. Looks like I’ll have to upgrade via clear net at least once to get next update. :unamused:

My location has Tor network being well known as unstable (Russian Federation).

I cant speak for Whonix, but there is no issue in updating over Tor.

On my side I see no tor (from 5 to 10 percent completeness while connecting). How can I recreate whonix vm using Dom0 console quickly to install-time-default state? This task should be already automated.

The installation program does this by default - creates “a clean whonix vm” that is a place where I’ve set it up as an “update qube”.

Also I see that dom0 gets somehow the updates are present and reminds me to run updater.

Remove existing qubes and templates.
sudo qubesctl state.apply qvm.anon-whonix
This will provide templates, sys-whonix and whonix-ws, and configure

dom0 checks etc, run through whatever you have set in global settings:
dom0 update qube.

I’ve removed tempates for sys-whonix and whonix-ws. I’ve set Dom0 update VM to work (and set it to have 4 Gb private space). I’ve typed ‘qubesctl state.apply qvm.anon-whonix’ but it fails telling me that
"ERROR: [Errno 2] No such file or directory: ‘/etc/qubes-rpc/qubes.TemplateSearch’ .

finally I’ve reinstalled the entire Qubes OS. :expressionless: Playing with tor as a transport seem to be expensive in time resources in Russia (where Tor is probably somewhat broken by ISP).
Though I’m not sure yet that problem is with Tor. Some chances that I triggered a bug in installation ISO: I’ve set it to use Moscow Russia Timezone and after that I had wrong time in Dom0 and all VMs. Hope that this is not intended especially for those who run Qubes in Russia, but just a usual bug. The bug is triggered by time in BIOS set not to UTC but to local time. I’ve seen similar bug in diffrent Linux distros long time ago. I’m slightly tired of my paranoia - finally I’ve to trust something & I like to trust Qubes. :slight_smile:

Anyway I’m about to post one more bug in installation program: auto generated partitions may lead to error installing linux firmware - you need to plan separate /boot/efi partition when you use dual boot (I use at least 3 OS booting ) and replace /boot/efi mount with your own partition prepared for use as efi . At least I have 3 efi partitions currently.