4.01 and 4.1 problem: fixing filesystem

4.01 and 4.1 problem: 1. ext4 filesystem damaged after HD ran out of space, 2. can’t boot the VM with a rescue live OS iso.
The whole filesystem seems erased and I have to try to restore it. I tried to boot live USB cd roms in the gui and in the cmd but nothing happens and the Fedora 36 VM boots normally. I don’t want to boot the VM and risk losing files on it. I cloned the VM just to have a snapshot of it.
What can I do?

Someone suggested to mount the partition on another VM. Any idea how that can be done?

Thanks(, “filesystem lover”). The mounting worked, but the fixing didn’t. testdisk resulted with nothing to repair. fsck just returned a number of files.

According to this article recovering ext4 files isn’t easy and often futile:

Looks like the only real answer is to backup, but in qubes backing up everything is very space demanding. What’s the best approach to backup only the changes on the file level and not the whole disk image?

EDIT: I tried ext4magic as well. DIdn’t help. Looks like when the HD space runs out in Qubes it can obliterate a VM without a trace of file fragments…?

it can’t do that

did you know why it ran out of space?
if possible, what exactly you do after it ran out of space?
sometime the thing you did just overwrite the data

Qubes ran out of space because the HD ran out of space…
Right after I deleted a VM to free up space.
I gave up on restoring the filesystem. The real question should be: how to backup automatically only changes to files (delta backups) instead of backing up the whole VM which can’t be done every day because it’s inefficient?

1 Like

If you are using the default LVM-thin configuration, I recommend:


1 Like

Thanks a lot for telling me about these but I wish Qubes provided a mechanism to do that automatically to a VM instead of having to set it up for each VM.