4.0.3 Qubes installation failure with Asus B460M-A motherboard

Hello everybody! At times I can be pretty long-winded, and especially now when I got a lot of time on my hands due to the lockdown in my country. So if you feel like it, just scroll down to the last two paragraphs of this posts.

So, since I was still using 3.x after it went EOL I figured it was time to buy new hardware that could run 4.x. The hardware I bought is:

Asus Prime B460M-A motherboard
Intel Core i5-10500 processor
Asus TPM-SPI card
16GB of memory
and two 250GB NVME drives

The reason it has two hard drives is because I want to make it a dual boot system with bare metal Windows and Qubes.

When I tried to install Windows for the first time the computer crashed…
After the computer rebooted the Windows installer said there was an error, but if I would connect the LAN cable it could download something that would probably fix the error, and it did.
Don’t know if this has any relevance, but it certainly was something I had never seen before.
I also was not able to reproduce the error, so not sure what the message was exactly.
Anyway, Windows is now installed with all the correct drivers for the hardware and Bitlocker is enabled using the TPM (can be disabled if necessary, just enabled it for test purposes).

So, now the real fun started. I have used the freshly installed Windows to download and verify the Qubes 4.0.3 ISO, and I have used Rufus (in DD Image mode) to copy the ISO onto a USB drive. After errors occurred during the installation of Qubes I pulled a very old laptop out of the closet. This laptop is running Antix (based on Debian Stable) and I used the laptop to again download and verify the Qubes 4.0.3 ISO, and used dd to copy the ISO onto a USB drive. In the end I used four different USB drives (Kingston DT50 8GB, Kingston DTM30 16GB, Kingston DTM30 64GB, Transcend Jetflash 780 8GB) but still the same errors occur during the installation of Qubes.

I found out that there is a difference when I preform an UEFI boot or a legacy boot. When preforming an UEFI boot it always crashes with a fatal page fault. I copied the information of the boot screen by hand, so there could be some errors due to copying.

Xen 4.8.5-14.fc25 (c/s ) EFI loader
Using configuration file 'BOOTX64.cfg'
vmlinuz: 0x000000006c55f000-0x000000006cbaaca0
initrd.img: 0x000000006b192000-0x000000006c55ab1c
0x0000:0x04:0x00.0x0: ROM: 0xe000 bytes at 0x62d03018

(XEN) ACPI: Invalid sleep control/status register data: 0:0x8:0x3 0:0x8:0x3
(XEN) ACPI: 32/64X FACS address mismatch in FADT - 88e52000/0000000000000000, using 32
(XEN) IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-119
(XEN) Enabling APIC mode:  Phys.  Using 1 I/O APICs
(XEN) Switched to APIC driver x2apic_cluster.
(XEN) xstate: size 0x440 and states 0x1f
(XEN) Unrecognised CPU model 0xa5 - assuming not reptpoline safe
(XEN) Unrecognised CPU model 0xa5 - assuming vulnerable to LazyFPU
(XEN) Speculative mitigation facilities:
(XEN)   Compiled-in support: INDIRECT_THUNK
(XEN)   Xen settings: BTI-Thunk JMP, SPEC_CTRL: IBRS+ SSBD-, Other: IBPB
(XEN)   XPTI (64-bit PV only): Dom0 disabled, DomU disabled
(XEN)   PV L1TF shadowing: Dom0 disabled, DomU disabled
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Platform timer is 23.999MHz HPET
(XEN) Detected 3096.216 MHz processor.
(XEN) Unknown cachability for MFNs 0xa0-0xff, assuming UC
(XEN) Unknown cachability for MFNs 0x4f000-0x8f7ff, assuming UC
(XEN) Initing memory sharing.
(XEN) CPU0: No irq handler for vector 6c (IRQ -2147483648, LAPIC)
(XEN) Intel VT-d iommu 0 supported page sizes: 4kB, 2MB, 1GB.
(XEN) Intel VT-d iommu 1 supported page sizes: 4kB, 2MB, 1GB.
(XEN) Intel VT-d Snoop Control not enabled.
(XEN) Intel VT-d Dom0 DMA Passthrough not enabled.
(XEN) Intel VT-d Queued Invalidation enabled.
(XEN) Intel VT-d Interrupt Remapping enabled.
(XEN) Intel VT-d Posted Interrupt not enabled.
(XEN) Intel VT-d Shared EPT tables enabled.
(XEN) I/O virtualisation enabled
(XEN) - Dom0 mode: Relaxed
(XEN) Interrupt remapping enabled
(XEN) Enabled directed EOI with ioapic_ack_old on!
(XEN)  -> Using old ACK method
(XEN) ----[ Xen-4.8.5-14.fc25  x86_64  debug=n   Not tainted ]----
(XEN) CPU:    0
(XEN) RIP:    e008:[<0000000089ee3d2a>] 0000000089ee3d2a
(XEN) RFLAGS: 0000000000010046   CONTEXT: hypervisor
(XEN) rax: 00000000fed00000   rbx: ffff82d080827c90   rcx: 0000000000000000
(XEN) rdx: 0000000000001830   rsi: 0000000089ec00e0   rdi: 0000000000000000
(XEN) rbp: 0000000089ec0140   rsp: ffff82d080827bd8   r8:  0000000089ee7bf8
(XEN) r9:  ffff82d080827cff   r10: ffff82d080827dff   r11: 0000000000000000
(XEN) r12: ffff82d0808586a0   r13: 0000000000001830   r14: 00000000000fd0dc
(XEN) r15: ffff82d080806615   cr0: 0000000080050033   cr4: 00000000003506e0
(XEN) cr3: 00000004602f2000   cr2: 00000000fed00010 
(XEN) fsb: 0000000000000000   gsb: 0000000000000000   gss: 0000000000000000
(XEN) ds: 0000   es: 0000   fs: 0000   gs: 0000   ss: 0000   cs: e008
(XEN) Xen code around <0000000089ee3d2a> (0000000089ee3d2a)
(XEN)  36 48 8b 05 c6 3e 00 00 <48> 8b 40 10 48 89 44 24 08 48 89 05 4e 4d 00 00
(XEN) Xen stack trace from rsp=ffff82d080827bd8:
(XEN)    0000000089edc6f9 0000000089ec0101 ffff010089ebe37d ffff82d080214726
(XEN)    0000000000000000 ffff82d0802147ef ffff82d0802147fb 0000000000000000
(XEN)    0000000089ebe785 ffff82d080827cb0 0000000000000000 00000000000002aa
(XEN)    0000000000000286 ffff82d080827c80 ffff82d080806e00 ffff82d0808066e0
(XEN)    000000000000000b 0000000000000206 ffff82d080817ef8 0000000000000206
(XEN)    ffff82d080211641 ffff82d0802147ef ffff82d080827cc0 0000000000000003
(XEN)    ffff82d080827d10 0000000000000000 0000000000000000 ff282d150d0107e5
(XEN)    0000000000000000 0000000000416000 ffff82d0808066e0 000000000000000b
(XEN)    0000000000000000 000000000003a981 0000000000000200 00000006e6fb2a56
(XEN)    ffff82d080827d40 ffff82d0808586a0 ffff82d080827fff ffff83046390ffe0
(XEN)    ffff82d0801886ed 0000000000000838 0000000000000000 0000000000000000
(XEN)    ffff82d0801886ed 000000f000000000 ffff82d08061d182 000000000000e008
(XEN)    0000000000000206 ffff82d080827d70 00000006e6fb2a56 ffff83046390ffe0
(XEN)    ffff82d0808586a0 ffff82d080827fff 000000000000000b ffff82d0808066e0
(XEN)    ffff82d08062c152 ffff82d0808586a0 ffff82d080627fb3 ffff83006d252e80
(XEN)    ffff83006d252220 00007d0000000002 ffff83006d23fd6b 00000000024ca000
(XEN)    ffff82d08064f7e0 0000000000000000 0000003a00000000 0000000004fe4000
(XEN)    000000000046f800 ffff82d080000000 ffff82d080000000 0000000000000000
(XEN)    0000000000000002 0000000000000002 0000000000000002 0000000000000003
(XEN)    0000000000000003 0000000000000004 0000000000000004 0000000000000005
(XEN) Xen call trace:
(XEN)    [<0000000089ee3d2a>] 0000000089ee3d2a
(XEN)    [<ffff82d080214726>] int80_direct_trap+0x116/0x11d
(XEN)    [<ffff82d0802147ef>] common-interrupt+0x8f/0x120
(XEN)    [<ffff82d0802147fb>] common-interrupt+0x9b/0x120
(XEN)    [<ffff82d080211641>] efi_get_time+0x71/0xc0
(XEN)    [<ffff82d0802147ef>] common-interrupt+0x8f/0x120
(XEN)    [<ffff82d0801886ed>] time.c#get_cmos_time+0x1cd/0x2a0
(XEN)    [<ffff82d0801886ed>] time.c#get_cmos_time+0x1cd/0x2a0
(XEN)    [<ffff82d08061d182>] setup_boot_APIC_clock+0x132/0x2d0
(XEN)    [<ffff82d08062c152>] init_xen_time+0xa2/0x140
(XEN)    [<ffff82d080627fb3>] __start_xen+0x2473/0x3650
(XEN) Pagetable walk from 00000000fed00010:
(XEN)  L4[0x000] = 00000004602f1063 ffffffffffffffff
(XEN)  L3[0x003] = 000000006d411063 ffffffffffffffff
(XEN)  L2[0x1f6] = 00000004602f4063 ffffffffffffffff
(XEN)  L1[0x100] = 0000000000000000 ffffffffffffffff
(XEN) **************************************** 
(XEN) Panic on CPU 0:
(XEN) [error_code=0000]
(XEN) Faulting linear address: 00000000fed00010
(XEN) ****************************************
(XEN) Reboot in five seconds...

But the reboot never happens.

When I preform a legacy boot I can see the Qubes OS boot screen and I can start the installation process. But when the process reaches anaconda I’m greeted with the “Not asking for VNC because we don’t have a network” / “X startup failed, aborting installation” error. In anaconda I do have a shell, so I could export log files (if I know where to find them) or the journal. (And probably do even more things I am not aware of.)

I consider myself a pretty tech-savvy guy, but when it comes to Linux I am a novice user at best. So any help installing Qubes would be greatly appreciated.

1 Like

In the last few days I tried some things myself, but unfortunately I have not made any progress.
I have removed the second NVME drive, and I removed the TPM-SPI card. But results are still the same.

So now the hardware is:

Asus Prime B460M-A motherboard
Intel Core i5-10500 processor
16GB of memory
a 250GB NVME drive

The gpu of the system is the Intel® UHD Graphics 630 which is integrated in de cpu.

The BIOS version is 1401, newer BIOS versions are Beta versions for ReSizable BAR support, so I did not upgrade to them.

VMX and VT-d are enabled in BIOS. But even when VMX and VT-d are disabled I still end up in anaconda with the “X startup failed, aborting installation” error.

Now I will post the content of the boot.log file which I found in /var/log, maybe this can offer some insight to my problem.


[[0;32m  OK  [0m] Started Show Plymouth Boot Screen.
[[0;32m  OK  [0m] Started Forward Password Requests to Plymouth Directory Watch.
[[0;32m  OK  [0m] Reached target Encrypted Volumes.
[[0;32m  OK  [0m] Reached target System Initialization.
[[0;32m  OK  [0m] Reached target Paths.
[[0;32m  OK  [0m] Reached target Basic System.
[   15.482700] dracut-initqueue[720]: mount: /dev/sda is write-protected, mounting read-only
[[0;32m  OK  [0m] Started dracut initqueue hook.
[[0;32m  OK  [0m] Reached target Remote File Systems (Pre).
[[0;32m  OK  [0m] Reached target Remote File Systems.
         Starting dracut pre-mount hook...
[[0;32m  OK  [0m] Started dracut pre-mount hook.
[[0;32m  OK  [0m] Reached target Initrd Root File System.
         Starting Reload Configuration from the Real Root...
[[0;32m  OK  [0m] Started Reload Configuration from the Real Root.
         Starting dracut mount hook...
[[0;32m  OK  [0m] Reached target Initrd File Systems.
[[0;32m  OK  [0m] Reached target Initrd Default Target.
[[0;32m  OK  [0m] Started dracut mount hook.
         Starting dracut pre-pivot and cleanup hook...
[[0;32m  OK  [0m] Started dracut pre-pivot and cleanup hook.
         Starting Cleaning Up and Shutting Down Daemons...
         Starting Plymouth switch root service...
         Stopping Device-Mapper Multipath Device Controller...
[[0;32m  OK  [0m] Stopped target Timers.
[[0;32m  OK  [0m] Stopped Cleaning Up and Shutting Down Daemons.
[[0;32m  OK  [0m] Stopped dracut pre-pivot and cleanup hook.
[[0;32m  OK  [0m] Stopped target Remote File Systems.
[[0;32m  OK  [0m] Stopped target Remote File Systems (Pre).
[[0;32m  OK  [0m] Stopped dracut mount hook.
[[0;32m  OK  [0m] Stopped dracut pre-mount hook.
[[0;32m  OK  [0m] Stopped dracut initqueue hook.
[[0;32m  OK  [0m] Stopped target Initrd Default Target.
[[0;32m  OK  [0m] Stopped target Basic System.
[[0;32m  OK  [0m] Stopped target Sockets.
[[0;32m  OK  [0m] Stopped target Paths.
[[0;32m  OK  [0m] Stopped target Slices.
[[0;32m  OK  [0m] Stopped target System Initialization.
[[0;32m  OK  0m] Stopped Create Volatile Files and Directories.
[[0;32m  OK  [0m] Stopped udev Coldplug all Devices.
[[0;32m  OK  [0m] Stopped dracut pre-trigger hook.
         Stopping udev Kernel Device Manager...
[[0;32m  OK  [0m] Stopped Apply Kernel Variables.
[[0;32m  OK  [0m] Stopped target Encrypted Volumes.
[[0;32m  OK  [0m] Stopped target Local File Systems.
[[0;32m  OK  [0m] Stopped target Swap.
[[0;32m  OK  [0m] Stopped Load Kernel Modules.
[[0;32m  OK  [0m] Stopped target Initrd Root Device.
[[0;32m  OK  [0m] Stopped Device-Mapper Multipath Device Controller.
[[0;32m  OK  [0m] Started Plymouth switch root service.
[[0;32m  OK  [0m] Stopped udev Kernel Device Manager.
[[0;32m  OK  [0m] Stopped dracut pre-udev hook.
[[0;32m  OK  [0m] Stopped dracut cmdline hook.
[[0;32m  OK  [0m] Stopped Create Static Device Nodes in /dev.
[[0;32m  OK  [0m] Stopped Create list of required sta...ce nodes for the current kernel.
[[0;32m  OK  [0m] Closed udev Control Socket.
[[0;32m  OK  [0m] Closed udev Kernel Socket.
         Starting Cleanup udevd DB...
[[0;32m  OK  [0m] Started Cleanup udevd DB.
[[0;32m  OK  [0m] Reached target Switch Root.
         Starting Switch Root...

I also wanted to post the content of the journal which I exported with journalctl, but this makes me go past the character limit of this forum with something like 5 times what is allowed…
The content of the journal can be found here: JustPaste.it - Share Text & Images the Easy Way

1 Like

(Hint: you can also upload a .log file by dragging and dropping it)


Hi @Jansen227,

Did you test the 4.0.4-rc2 ISO? (it includes a newer kernel).

Check the RAM dedicated to your included GPU in the BIOS settings.

Did you check all the required BIOS settings? see installation-guide

Note: I’m using a i7-10710U with Qubes OS 4.0.3 (updated, so 4.0.4).


DVMT Pre-Allocated is set to the default value of 64M. From what I understand it is not nessecary to change this value because with DVMT more memory is allocated dynamically when needed.

Yes, I followed the installation-guide to the letter. Intel VT-d and VT-x (VMX) are enabled, and fast boot was disabled.

You sir, are a godsend. I tried a lot of different things, but it never crossed my mind to try the rc2 ISO. UEFI boot gave me a blank screen after “Xen is relinquishing VGA console”, but when I tried legacy boot the installer showed up and Qubes installed without any problems. Thanks!


(The TPM on the motherboard is 2.0 so it can’t be used for AEM (yet?). But after I did some reading I don’t even want to use AEM. But luckily I can still use the TPM for BitLocker.)

1 Like

Hi @Jansen227 ,

Good news :+1:, welcome to the Qubes world!

Now, do your tests and experiments, read the Qubes OS documentation which contains a lot of useful details.

1 Like

Hi @Jansen227. Glad you manged to figure it out. I generally rename the topics of what concretely was the problem so others in the same situation can find it.

But in this case I’m having a hard time knowing what concretely were the symptoms you were experiencing.
Would you be able to help me? If you were to describe your issue in around six words, what would you say it was?

1 Like

I understand what you are trying to do, but even for me it’s hard to exactly point out the problem.
In hindsight it’s easy to say 4.0.3 was the problem, and using 4.0.4-rc2 solved it, but I still have no idea what the core of the problem really is.

I guess “4.0.3 fails to install, tried everything” would be a slightly better topic title, but still not fantastic.

Hi @deeplow ,
it’s a hardware compatibility issue with the 4.0.3 Qubes default kernel, so I suggest 4.0.3 Qubes installation failure with Asus B460M-A motherboard


I’ll go with 4.0.3 Qubes installation failure with Asus B460M-A motherboard. And I guess classify it as a hardware-related issue. Thanks @Jansen227 @ludovic

1 Like