2 usb related questions

I’m going nuts over this…

  1. I have a read-only usb that I attach to a qube and I want to set it’s permissions to writable, but I can’t. I can’t even format it. The usual thing to unmount and mount with permissions don’t work, as when I unmount I don’t see the usb(the path e.g. /dev/sda) in the terminal of that qube.
    So how do I format it?
    and how do I grant write permissions if I need to, for the entire usb?

  2. I also want to make a bootable some windows usb that etcher won’t make it bootable. so I tried like billion ways and I can’t make this little shit bootable including running rufus with wine(because rufus with wine works only with version 3.2 or whatever and it doesn’t even see the usb) and nothing helps. like seriously… what the…
    Isn’t there like a some tiny program to handle this in a sane way without want me to end my life?

1 Like
1 Like

I forgot to mention it, but I’ve tried it and it actually printed that all went good, but it wasn’t bootable. I was trying to make a dban usb to wipe a disk in a secure manner.

1 Like

Okay, try Ventoy:

Never heard of this ventoy thing before, thanks for bringing this up. I’ve tried it, but the same with woeusb, it just don’t boot. Maybe there’s an issue with dban? I don’t know how to test this, as I don’t have an idea what other windows bootable media can I download and try.

1 Like

Does your read-only USB drive have different behaviour when accessed using a different operating system?