Your experiences with Qubes as daily driver?

Hi all,

I would like to hear what other people’s experienes are with Qubes as a daily driver OS.

For example, is it common to have issues after updating Qubes? How often do you run into issues? What are your experiences with your workflow on Qubes?

If I’m honest I feel stuck between a rock and a hard place.

Using Qubes as a daily driver, to me, a very low level nerd with limited Linux skills, seems to be pretty hard work, with some things being cumbersome and random issues cropping up now and then, both taking a lot of time and making the workflow a lot slower than say on Mint.

At the same time, I dislike the thought of going back to Mint, for all the reasons that made me switch to Qubes in the first place…

Is this just the price we all pay?

Or am I the only one, and I just need to toughen up, learn more, and wait until I’m able to use Qubes without it bringing my workflow to a grinding halt at random intervals?

/end rant

Just to be clear, I massively appreciate what you all do!

I wish I had the skills to run Qubes and not need so much help to deal with its limitations and issues. Grateful that that help exists…


1 Like

Hi Jack,

I hear your frustration. You’ll find out that the experiences that we all have depend in great part on our expectations, what we’re trying to do, and how much some of the most fundamental choices in the design of Qubes OS meet our own needs for security and convenience. There is often (though not always!) a trade off to be made between security and convenience that is very personal.

Here is what some others folks have already shared:


I’d add that:

  1. Qubes taught me I had a lot of “needs” I eventually got rid off which got me a lot more time for real life.
  2. For some of my real needs, Qubes taught me what are better ways to fulfill them, even if I became aware afterward about advantages.
  3. It’s all about awareness. It was always, and always will be: what one asks, she’ll eventually get. If she asks for reasons not to use Qubes, she’ll find them. If she finds not using Qubes out of question, she’ll find her ways and learn so much on the road. It’s not a highway, but any serious driver would tell you highways are boring and more worse, more dangerous than offroads.

Out of highways, the driver has to be much more concentrated but it’s also more enjoyable for the driver. Daily, If you get this word-game.

No, never. If you have any related issues, you should create a topic here and explain in detail what happens. The Community will try to help you.

Almost never, except few known issues. For me, layout switching is currently the actual problem. Also, the general slowness of opening new VMs, but it’s pretty tolerable.

Can you specify precisely what your current pain points are and how you meet them in your workflow?

1 Like

A lot of issues, actually. Some of them:

  • Layout switching is broken starting from R4.1 release,
  • youtube and any other video-players are not working smoothly and are CPU consuming,
  • Qubes do not start if they are HVM that have like more than ~950 MiB of memory,
  • XFCE is dull and messy, also can be broken easily (happened to me several times),
  • Updates of template break things (but the same for Fedora, so it’s not Qubes OS fault),
  • IO in one qubes freezes other qubes,
  • Windows qubes are not working all that good (better than it was 2 years ago, but worse than on GNU/Linux in VirtualBox),
  • Updating things across multiple qubes and templates is time-consuming (but I made a lot of own stuff and scripts to optimize it),

But I still use Qubes OS. There is no alternative OS on the market that can reliably prevent inter-application disk and clipboard interactions.

If there were no Qubes OS I would run GNU/Linux with a lot of virtual machines in VirtualBox or qemu.

We’ve talked before about how specific some of these are to you, and how
most users dont experience such problems.
Layout switching and Xfce horribleness are undisputed.
Video playback is “good enough” for most users, on their hardware, as
you’ve been told by other users.
HVM with more than 1GB memory? Not a problem I recognise, or the users I
Windows use? No complaints from my users.
Updates? A new updater is being worked on - you can reduce time and
bandwidth use by using a caching proxy - much discussed in this forum.
Inter qube freezing? Entirely dependent on what you are doing. If you
mean disk IO, then even on a humble x230 I rarely see this. Memory
intensive application? Sometimes. I would say that changes in memory
management make it more likely that you will see issues when starting and
shutting down qubes than with 4.0

Amen to that.

@Jack - what issues you encounter will be determined by what you want to
use Qubes for, what hardware you choose, and what your priorities are.
You see, if your priority is to work while keeping data as secure as
possible on a consumer system, then you wont encounter “issues”. You’ll
find some niggles, but nothing major.
If your priority is to watch Youtube HD on multiple screens while doing
some gaming on the side, then you will hit major issues.

All I can say is that for many users, (I suspect the silent majority),
they just get on with using Qubes, leveraging compartmentalisation to
increase their security profile.
For almost all the users I support, the level of issues is about the
same as supporting a standard IT system. Familiarisation with the OS,
and not over reaching, are important to that.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.
1 Like

But the topic starter @Jack asked everybody about their experience, so of course I am answering according to my experience and expectations.

On the other hand there are people who are also not that happy by the absence of smoothness in youtube and other video players.

I have it right now. 950 MiB is not a magic number, sometimes it is more (up to 2GiB probably) or even less. But it is a known (and multiple times reported) problem.
Related problem: Possible to Fix 2048MB RAM Limit for NVIDIA GPU Passthrough to HVM?

At least I have Alt+tab not working properly. It is kind of big deal. How your users overcome or work-around this? I have Alt+Tab in muscle memory and using Win10 qube is painful due to this bug:

It is not about time of the process or bandwidth at all. It is about having multiple templates (different package sets and even Fedora version and updating all them by installing something. I manage it with self-made bash scripts.

I am tracking several issues on github about this. It exists. In my case it is about disk/usb or memory IO, or CPU. Even cursor starts being choppy, reproducible half of the time. On previous and older PC with Qubes OS 3.*-4.0 I was not having this bug at all.

Please, note, that the post was made not to criticize Qubes OS, but admit that there is a room for improvement. I am also trying to solve issues and publish solutions or work-arounds when possible (including github).

1 Like

I’ve been using Qubes OS as a daily driver since end of 2019. I’m not switching back. Actually I can’t, now that I discovered the exceptional flexibility Qubes OS offers.

I faced two types of challenges: the learning curve, and the ongoing “challenges.”

If I remember correctly, it took me a couple of months to properly master Qubes OS. Initially, I ran it as a dual boot with Windows. Coming from Windows, I needed to figure out the Linux software ecosystem, which wasn’t that hard. Installing a VPN Qube required also copy/pasting to Terminal. But the instructions in the Qubes OS documentation were straightforward. Finally, I installed Windows using elliotkillick’s script - after a dozen failed attempts using all other methods.

My main ongoing “challenges” are the need to install a new Fedora template regularly, and reinstalling Qubes OS in full every time there’s a new version (4.0, 4.1, 4.2). I also need to manually install and update Zoom in a template. Installing some software requires some command-line terminal typing (example, adding repositories for Brave or enabling repositories for VLC in Fedora). A few common tasks would take a few seconds more to complete on Qubes vs. another system (attaching a drive or camera to a Qube, copying files from/to Qube).

I faced no problem with playing video even on older laptops. Layout switching works. On a few rare occasions, a disposable VM did not inherit the right keyboard layout.

But after several years of using Qubes, I don’t mind wasting a bit of time for some of the extra steps Qubes OS requires. It’s a great daily driver.


Try with brave and or in minimal dispVM with

sudo dnf install pulseaudio pulseaudio-qubes qubes-audio-daemon qubes-core-agent-networking qubes-split-browser-disp tinyproxy --allowerasing

installed in its template (or in any other browser’s template, if you prefer)

sudo dnf config-manager --add-repo\

export http_proxy=
export https_proxy=
sudo rpm --import ILI
sudo curl --proxy localhost:8082 > brave-core.asc
sudo rpm --import ./brave-core.asc
sudo dnf update
sudo dnf upgrade --refresh
sudo dnf install brave-browser

Yes, but it is no help to other users to understand your experiences
unless you make it clear what your position is, and what your expectations
I’m not trying to invalidate your experience - I am saying that users
should provide detail when they are reporting issues.
So you dont have an issue with HVM qubes starting with 1GB allocated -
you do have a problem with HVM qubes with GPU pass through configured,
so starting.
Unless you provide that extra detail, your report is misleading at best,
and unhelpful to other users.

This is very common in the forum - users report issues as a general
problem when some probing shows it is either their hardware or qube
configuration that results in the problem.
Sometimes it’s PEBCAK.

On Alt+Tab in Windows, this is a general issue where dom0 captures
certain key combinations.
If a user works mainly in Windows, I remove that dom0 shortcut. If they
divide time between Windows and other qubes, I have a script that
removes the shortcut when a Windows qube is active and restores it when
inactive. Seems to work ok.

@jack - fsflover gave good advice. It’s not a question of toughening up.
I can see you’ve posted a few questions about problems that you have
encountered - keep asking.
The x230 is a great machine - I dont recognise the WiFi issue you
reported, but I’ve asked some questions there, and we should be able to
get that resolved.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.


1 Like

Well, no, I do have the issue with HVM having USB controller. I did not went into details here (in this topic) just because it does not seem to be a place for it. Github bug report exists and it is open:

I mentioned link about GPU and memory limitation as an additional related example, I personally do not have external GPU, sorry that it was misleading.


  • All issues that I mentioned are reported on github and all are open (unsolved),
  • I skipped all issues that I personally had with Qubes OS but that are fixed by today (dozens of them).
  • I also skipped a lot of issues that I still have, that are reported to github, still unsolved, but are either too specific or I have somewhat work-around (also more than a dozen).

I was considering to make the same script.
Can you please share it?

Another major issue I have (and a lot of other people according to github and forum) - Qubes OS does not support sleep on modern Thinkpads. And those are almost the only modern devices which actually support S3, we are not talking about all other modern laptops without S3 - no sleep/resume for them either.

So, I have on my laptop an OS that is not working properly with keyboard layout switching and force-reboots on suspend. Frustrating a bit.

Kubuntu works perfectly well on the same hardware, so it is not a Linux kernel issue but Qubes OS (maybe xen).

Can you please share this solution?

i use a L14 Gen3 Intel and suspending works with kernal-latest or kernel 6.1 in app-vms. debian and fedora templates wake up properly and my fedora sysnet reconnects to wifi. (xen is 4.14.5)

1 Like

I have T16 Gen1.
I am following this issue on github and forum posts.

1 Like