XFCE4 Panel Style Issue

After fresh install Qubes-R4.1.2-x86_64 i have bug with xfce4-panel
after change appearance to dark, to apply style to xfce panle i need to open terminal and type

xfce4-panel -r

without that style will not apply to panel
The worst is, i need to do this every time after restart.
Every time i need to open terminal and restart panel to make it dark

I don’t know if there’s a neater solution (keep in mind I’m new to Qubes) but I simply added xfce4-panel --restart to Xfce’s Session and Startup in dom0 (Application menu → System tools → Session and Startup → Application Autostart).

XFCE is full of such bugs.

I also had xfce4-panel broken several times just by changing settings via xfce settings GUI. Yes, xfce4-panel -r was fixing the issue for me too, but only till the reboot.
I reported this problems on github, but it is kind of random, hard to diagnose and, thus, it is not fixed, unfortunately.

The way I resolved my situation: create directory in dom0, move all configs related to xfce4 and xfce4-panel there and after re-login or reboot everything will be reset to the original state and default configs will be regenerated.
Then I had to manually customize everything again and hope that this time xfce4-panel and other xfce4-related stuff would not be broken. Sometimes I had to do it twice because it was broken again.