X startup failed on Lenovo ThinkBook 15 IIL

I am getting “X startup failed” before the installer screen on my Lenovo ThinkBook 15 IIL. I have tried a couple of alternate startup lines to no avail.

The installer script suggests “try again with the inst.text bootoption to start text installation”. I tried appending --inst.text to the startup line, but got the same error as before.

Someone else had graphics driver issues and replaced vesa with intel (and removed nomodeset). My machine has Intel graphics, so I tried that, but got the same error as before.

Any suggestions?

I tried adding inst.text nomodeset before quiet as suggested on GitHub but encountered problems with the text-based installer (mentioned in the same GitHub post :frowning: ).

Next steps:

  • Investigate what kickstart is.
  • Try again with GUI.

@lofidevops this could be related to UEFI have you tried to boot the installation media in Legacy mode ?


@Plexus Thanks for the tip! I can now get to the installer after:

  1. Enabling UEFI
  2. Disabling secure boot
  3. Putting USB at the top of the boot order

As mentioned in the docs, this skips the boot screen and goes straight to the installer.

I will try and collate my notes once I’m done :wink:

I have the same laptop and the same problem, but the same solution didn’t give me success. I’m using the 4.0.4 installer. Do you recall if you needed to do anything else to make it work?

Perhaps I need to use an older version installer and then upgrade from there? I know that this version drops directly into [qubes-verbose] installer and doesn’t give any grub prompts for this version. Maybe you had success on a version that did?

I’ve tried a few things. I tried xdriver=intel and I’ve tried console=none and I’ve tried inst.text, all without success.

If the exact installation procedure does not work, then it could be related to the BIOS version. So an update to that could be needed. Idk.