[WIP] Windows/QWT user reports

You need to increase VM private volume size I guess.

1 Like

ok, thanks! That was the point.
The thing is, after I installed it in Windows10, it has no effect no anything.
Maby it’s because I had there the old version of qubes tools?
Or maby it’s because I restored Win10 from the backup made in Qubes 4.0?
Anyway Windows10 crushes after some time (but I think, thats another problem).

Windows VMs in Qubes R4.1 tend to crash when they are restored from an R4.0 backup. See Migrate backups of Windows VMs created under Qubes R4.0 to R4.1 for a discussion and some hints on how to fix the problems from changing the disk drivers.

1 Like

Ok, Thanks!

But what about the installation of the qubes tools? They had no effect on my Win10. Is also because of the problem of restoring from the 4.0-backup?

You will need QWT 4.1.67 - the old QWT probably will not work under Qubes R4.1. See tabit-pro / qubes-windows-tools-cross

I’ve made all the steps below and installed it… but no effect.

@ all : fyi I’ve made quite a few edits/additions to the wiki (most important addition is the link to @jevank’s binary releases).

What do you mean by “no effect”: none of QWT’s features work, or just a subset ?

can not copy to other VMs for example. So I think that the futures do not work.

2 posts were split to a new topic: Trouble copying text out of a Windows qube (wrong formatting)

Is there any update on qvm-create-windows-qube and QWT being integrated directly into the qubes repos?
I haven’t used either as, last time I checked, you have to manually build QWT on 4.1

  • qvm-create-windows-qube: no feedback from the author about 4.1 (see the related issue).
  • QWT official integration: see @marmarek’s comment (continuous integration is being worked on).

No need to build QWT, just download the binary release.

I just created a new issue Provide information on integrating Windows into Qubes R4.1 #7381pointing to 2 pull requests for instructions about installing a Windows qube and installing QWT 4.1.67, as well as on migrating Windows VMs from Qubes R4.0 to R4.1.

The instructions in these pull requests are just a first draft - any comments and improvements are highly welcome!

1 Like

@jevank jevank 7 hours ago

Audio … will work with features enabled (stubdom-qrexec and audio-model)

… if audiovm is dom0. If audiovm is sys-audio so far it doesn’t work, or I am not aware of it. I think this is not irrelevant since we are talking about 4.1 and sys-gui and sys-audio are 2 of the biggest changes and innovations and, more important, trends.

Fair enough, I hope we can work it out. But sys-audio and sys-gui are more of a tech preview as I understand it



I patched qemu-stubdom-linux-full-rootfs and changed the domid of module-vchan-sink from 0 to the xid of sys-audio, this is more of a workaround than a solution but at least I have working audio on Windows.

1 Like

A post was split to a new topic: Qubes 4.1 + Windows 7 (w/ QWT) crashes

The docs note" An unofficial, third-party tool for automating this process is available here. (Please note that this tool has not been reviewed by the Qubes OS Project. Use it at your own risk.) However, if you are an expert or want to do it manually you may continue below."

I would love to have a better understanding of the difference between these approaches. Is it simply a question of ease of install, or does the qvm-create-windows-qube project provide any features that would not be present with such a manual install? My use case would be a single Windows 10 offline qube that needs QWT.

Relatedly, is qvm-create-windows-qube working on 4.1? This issue gives me the impression it isn’t.

I installed Windows 10 Pro with QWT following these instructions:

I have to say that Windows qube worked way-way better than it was in case of R4.0 and QWT of that time. Only ones qube hung and I had to pause and kill it (maybe Windows got crashed). On R4.0 several times I got even dom0 affected and had to reboot PC to keep using it.

Thanks to @GWeck and all other responsible for this significant improvements!

**What works after QWT installation: **

  • Sound (ich6 seems to be better than ich9, but not sure)
  • Copying files to and from Windows qubes. I found a possible bug - if I copy file from a subst-ed disk - the QWT copying tool does not work but shows error with something about permissions.
  • Copying clipboard to and from Windows qube.

What problems I have:

  • Alt+tab is not working, because it is caught by dom0. I understand the problem, do not know how to solve it properly.
  • Alt, Win and other modifier keys get stuck in many cases. E.g. not only Alt+Tab does not work for switching windows inside the qubes, but it also leaves Alt key pressed inside Windows qube. And pressing anything there leads to Alt+ combination and breaks stuff. So, I have to press Alt, Ctrl, Win, Shift one by one to sort of “un-stuck”. It is a most inconvinient issue for me now, if somebody knows how if with or workaround it - please tell.

What would happen if one was to change either the dom0’s binds to switch windows or use an AutoHotkey script to re-bind the keys used to switch windows inside Windows?

Alternatively just use the taskbar to switch windows as I do when RDPing to my work machine.

If I unbind Alt+Tab in the infamous xfce inside dom0 then Alt+Tab works properly inside Windows qube and Alt key does not get stuck in this case.

Just to be clear - everybody has not working Alt-Tab inside any Windows qube, even with QWT installed, right?