Windows support in Qubes

https://googlethatforyou.com?q=qubes%20build

(Sorry. For this to be the very next question after @unman’s remark about searching… I just couldn’t resist. :stuck_out_tongue: Anyway, the results actually are what you’re asking for.)

Thanks and few words to your results.

QWT for Windows 7 has special driver that implements virtual graphic device which doesn’t support changing resolution via system preferences. Instead of it you can just resize window, but first you need to allow it in window manager. Simple way I know for XFCE is Alt+right click+drag it. Unfortunately it does not work in Windows 10 where screen resolution defines with bios emulator.

As for application launch and seamless mode I will check and write latter… Haven’t seen such problems…

Some new results: I installed QWT to new, virgin W7 and W10 VMs, selecting all components including the Xen Disk and Network drivers. Both installs succeeded.

For W7, trying to resize the window by drag and drop had the funny effect that the window just moved and, as soon as I released the mouse button, it jumped back to its old location. Trying to set the window to full screen had the same effect.

For W10, the cursor took the shape that it has during resizing, but the window just moved, retaining its old size, but after releasing the mouse button, it stayed at its new location. Here, the window has no full screen button on the top right, and selecting full screen from the window menu had no effect at all.

1 Like

I tried to reinstall QWT on clean windows 7 and can’t reproduce fails with application launch via XFCE menu. Are you sure you have not using disposable launchers?..

Did you try resize with ALT + Right click and dragging? Without this action no resize available in context menu on window title…

For me, application launch works with Windows 10, but not with Windows 7. I just use the standard XFCE menu coming with Qubes, nothing special. What are disposable launchers, by the way?

ALT + right click does nothing in my environment. Just left clicking on the window menu button at the left end of the window title shows the window manipulation menu, but with the size change command greyed out (for both W7 and W10).

Changing the window size from the Windows cotrol panel function works for W10 for the few sizes that are supported. For Windows 7, just the large size (1920 x 1024) seems to be supported. Trying to select the other size (800 x 600) gives a warning, and then the system is unresponsive until a timeout occurs, and the size then stays at the larger value.

I mean launcher to start disposable vm when you mark qube as template_for_dispvms.
Could you try remove all application from selected in Qubes Settings Tab and than add it again. Perhaps you have some old files from previous tests.

Perhaps I can’t explain it clearly. This tutorial might help How to resize Xfce windows the easy way | ArcoLinux

I have enjoyed reading this thread.

I have been looking at Qubes for over a year now and recently started using as my daily driver only because I was able to get Windows 10 working (without video/audio/microphone support) to be able to fall back onto some applications that are not available in Linux.

Obviously a better integration of Windows 10 will increase our privacy and attract consciously aware users will be more inclined to start migration journey into world of Linux.

I hope that I make sense.

3 Likes

Thanks for your patience and help!

No, I don’t use a disposable VM when trying to execute a command in a Windows VM from the XFCE menu. My last tests with newly created VMs got different results: For Windows 10, the command was executed in the VM, but for Windows 7, where this is more needed, nothing happens.

I tried now to resize the windows via Alt + Right Drag, but, for both W7 and W10, the windows just moved but did not change their sizes, and the W7 window just popped nack to its old location afterwards. For W7 in seamless mode, the application windows behave normally and can be resized.

I will try win7 from @elliotkillick repo and check with it.

I tried qvm-create-windows-qube with R4.1 and QWT-cross and it works quite well.
At now it needs to allow file copying in deprecated policy file, so first we have to create it

dom0: sudo touch /etc/qubes-rpc/policy/qubes.Filecopy

Then all works as usual except QWT installation, which is need to be done manual in opened window. This is because of MSI package instead of exe file, but I think it will not be a problem to automate.

Second manual action is choosing target on Filecopy operation to copy files to windows qube at one of last stages.

@GWeck application launch from menu didn’t get any problem. Could you try this commands to recreate menu items with your case
qvm-appmenus --remove [windows-qube]
qvm-sync-appmenus [windows-qube]

If it not helps show output of manual starting application
qvm-run -p --service [windows-qube] qubes.StartApp+Accessories-Paint

UPDATED: I checked only win7x64-ultimate iso

Thank you for this thread, @gweck!

FWIW: In the recent surveys we’ve run, we’ve gotten MANY requests for Windows 10 support. I don’t think there’s anyone who does not want it, tbh.

Resourcing is the 100% issue. Short of a community contribution coming in that can be fully tested and fully resiliant and fully functional. Which is how this designer is trying to say “works!” but isn’t quite sure how to in this world I understand to be absudly complicated—but for good reasons.

Please do not let my assertions above, interfere with folks trying to crack this tough nut. Just wanted to chime-in that it IS a desired feature by many, and that the only reason the core team has not “prioritized it” (BIG air-quotes) is because it is but a toilet in the bathroom that is Qubes OS… and the core team is all 100% right now on keeping the water running and draining well.

3 Likes

Comparing Windows with a toilet is very apt !!!:slight_smile:

1 Like

Recreating the menu item via qvm-appmenus --remove and qvm-sync-appmenus did the trick: Now Windows 7 applications can be started from the XFCE menu, too.

By the way, I am using Windows 7 SP1 Professional, fully updated.

Good news!

The topic turned out more about QWT, so in order not to mix up I made a separate one for testing USB devices with Windows.

1 Like

To make long story short, did anyone manage to create a script for single-click win10 template deployment with modern QWT that would not require any manual trickery in the middle?

Take a look to qvm-create-windows-qube project and my message about it with 4.1

In line 113, install.sh of that project is:

sudo qubes-dom0-update -y qubes-windows-tools

But that command doesn’t work for me. When I run that in a terminal of dom0, I get:

No match for argument qubes-windows-tools

I installed a new qubes os 4.1 beta1 directly from the iso, instead of upgrading from 4.0.

You can build it with instructions and copy to dom0 after that
qvm-run -p dispXXX -- cat /home/user/qubes-builder/qubes-packages-mirror-repo/dom0-fc32/rpm/qubes-windows-tools*.noarch.rpm > qubes-windows-tool.rpm

In qubes os 4.1, the disposable qubes are based on fedora 34, but the dom0 is based on fedora 32.

Should I create a disposable qube based on fedora 32 to setup the build environment for qubes-builder?

By the way, after reading the install.sh of the qvm-create-windows-qube project, I don’t think it builds the qubes-windows-tools package for dom0.

I tested it with fedora 33 disposable vm, but 34 might be ok too. Don’t forget to increase private storage