Windows 7 qube cannot attach HDD's larger than 2TB

I’ve been trying to attach external HDD’s larger than 2TB in v.4.1 beta 1, 4.1 rc1 and now fully updated rc1 (probably automatically updated to rc2), but cannot succeed.

I have fully working Win7 standalone HVM as well as fully working TemplateVM and dvm’s, all with qwt 4.1.65 and Windows USB integration via QEMU emulation. Everything works as expected except attaching such HDD’s. Same HDD’s are possible to attach to non-win qubes.

I can’t attach them via device widget nether as block devices nor USB devices, nor via terminal.

Is there any help, or advice?

Is there any error shown?

Is it possible these 2TB drives are using 4096 byte blocks instead of 512 byte blocks? Is the partition scheme MBR or GPT?

@fsflover It tries to install the driver, then HDD detaches from the cube, and the error in qube is shown that driver cannot be installed because the drive is (meanwhile) unplugged. After that it disappears from the dom0 device list, so I have to unplug it and plug it back to the port.


Sector size (logical/physical): 512 bytes / 4096 bytes
Disklabel type: dos
Partition Table: loop (Parted has a way of identifying drives that have not partition tables but have a filesystem. Its the loop type. Usually, when loop is present it means that there is no recognizable partition table but there is a recognizable file system in the device?)

have the drive formatted?

Unfortunately, that is not an option, at least for now.

Windows management
Partition style: GPT


Are you attaching the usb drive to the windows 7 qube or are you attaching only the partition?

Neither works, as I wrote in OP… I tried different ports/controllers with no luck.

Does anyone can attach >2TB HDD to win 7 qube, or am I so lucky to be the only one around with such a combination, hahaha.

I attach a locally attached 8GB SATA drive to Windows 7 using the devices drop down from time to time, yes.

I wonder if the USB bridge on your >2TB drive supports UAS (USB Attached SCSI), is seen by sys-usb that way, and can be attached just fine to all Linux VMs, but fails with Windows 7 since Windows 7 only supports USB Mass Storage (low performance) and not USB Attached SCSI (high performance) connections.

Have you tried with a Windows 10 VM?

It’s possible the bridge chip supports USB Mass Storage for < 2TB drives, but anything above that threshold might trigger USB Attached SCSI mode only (and that mode is not supported by Windows 7).

See here for an overlapping discussion: Anyone know why older USB drive cases have a 2TB size limit – iTecTec


Thanks for your response @brendanhoar. The bridge obviously supports USB Attached SCSI connections, since I checked it above on the other win7 only laptop in order to get the partition table. It work flawlessly on native win7. It just doesn’t want to work in win7 qube,
I didn’t try with a win10 qube, since I don’t have one, and I am not sure I will ever use one. Probably will use win11 qube when the time comes.

What I didn’t understand from your response is:

  • you probably mistyped 8GB instead 8TB?
  • if it’s 8TB, does it work in your native win7 machine, or in a win7 qube?
  • if it’s qube, does it work attached both as an USB and a block device, or not?
  • If it’s win7 qube, which Qubes version you are running, and if it’s >= 4.1, do you have both qwt 4.1.65 and Windows USB integration via QEMU emulation installed like me or not?

Best regards

Ok, Windows 7 ships with UMS drivers but does not ship with UAS drivers…only windows 8 and later have UAS support.

Now a couple of motherboard manufacturers licensed 3rd-party-developerd UAS drivers for use on their USB 3.0 hardware under Windows 7, locked to those chipsets. But the chances are low that your laptop just so happens to be one of those models (some ASUS models…and one other laptop manufacturer, I think?).

When you attach this > 2TB USB device to the linux VMs, does it appear as a UAS or a UMS device. E.g. using lsusb, such as in this posting here: How can I check whether USB3.0 UASP (USB Attached SCSI Protocol) mode is enabled in Linux? - Super User

  1. Yes, I meant 8TB. My apologies.
  2. I attach the 8TB SATA block device to a win7 MV in qubes.
  3. Mine is not a USB device, it is a SATA device connected directly to the motherboard. Therefore, it’s attached as a block device and does not depend on the usbip layer.
  4. I am running Qubes 4.0 on that machine. The VM has a mismash of QWT 4.0.1.x from a couple of years ago, with the Windows PV Disk drivers installed, but likely updated to 8.2.2 Windows PV Disk drivers from the Xen site and not the ones available in the QWT ISO, which I believe are older and buggier.

So I see your point that you’re talking Apples (using the new Windows USB integration) and I am talking Oranges (just SATA devices).

So, let’s see if we can use that post above to ascertain if the device is being mounted in sys-usb as UAS or UMS before continuing. :slight_smile:


Might be interesting to disable UAS/UASP for that device in the source VM (sys-usb or dom0) and see if that impacts ability to attach device to Linux and Windows 7 VMs? Link for forcing USB Mass Storage BOT mode instead of UAS: Disable UAS - Leo's Notes

Thanks for your time and for your ideas @brendanhoar.
My HDD is definitely UAS device, so I tried to disable it. Here’s what I did:

lsmod | grep -i usb_storage;

usb_storage 81920 1 uas

lsusb -t

Port x: Dev y, If 0, Class=Mass Storage, Driver=uas, 5000M

rmmod didn’t work for me in any combination

rmmod usb-storage

rmmod: ERROR: Module usb_storage is in use by: uas

sudo rmmod -f usb_storage

rmmod: ERROR: could not remove ‘usb_storage’: Resource temporarily unavailable

so I had to use modprobe

sudo modprobe -r uas usb_storage

here I get a notfication in dom0 that HDD is removed

sudo modprobe usb-storage quirks=HDD-ID
lsusb -t

Port x: Dev y, If 0, Class=Mass Storage, Driver=, 5000M???

So it doesn’t give me Driver=usb-storage

From there I tried to attach it to win 7 qube via qvm-usb, but nothing happens.

If i try to physically reattach HDD, it is somehow expected not to be recognized by lsusb? No traces of quirks in sudo dmesg as well.

The only way to get HDD back is to restart the qube which automatically gives back uas (I don’t dare to permanently disable uas), so I am pretty lost at that point how to disable uas for HDD, yet it to be visible somehow so I could try to attach it as usb-storage to win7 cube…

But then it turned out actually that…