WiFi password does not work


I am coming from openSUSE. Qubes OS is still very new to me and I am willing to learn.

One problem I am currently facing is WiFi authentication. Here is what happens:

  1. I plug the USB wireless adapter (TP-Link, using rtl8188eu driver).
  2. I attach that device to sys-usb
  3. I set up the wifi conecion in nm-applet the same way as on my openSUSE laptop, using the exact same wifi password (I use my phone as a wifi hotspot)
  4. I click the connection to connect

What happens is:

The connection gets instantly disconnected on every attempt. This practically denies any attempt to connect to the Internet. The only workaround I have found is not to use wifi password at all (which of course is not desired as it is insecure). Only then I was able to connect and update the system. Unfortunately, even after update and reboot the problem remains.

Using the exact same USB wireless adapter on openSUSE works just fine - password is accepted. Of course, I checked many times, even with a very simple password, so, I am 100% sure that the password is typed correctly.

I tried to use another USB wifi adapter (which also works fine on openSUSE) but that one won’t even attempt to connect (more errors are seen in journal).

So, I am hoping to get some help here.

Describing your sys-usb would help better, I guess. I would also try kernel-latest-qubes-vm for sys-usb.

Thank you for the quick reply.

Describing your sys-usb would help better, I guess.

What does this mean? The sys-usb was created automatically when I installed Qubes OS. During the installation I also installed whonix with the option to run system updates through Tor. I have not made any expert customizations.

Please let me know if that answers your question or whether I should provide other info.

I would also try kernel-latest-qubes-vm for sys-usb.

How do I do this, please?

OK, so your sys-usb is not disposable.

Would you want to try, just follow this.

1 Like

Thank you.

It seems that was not necessary. Today I tried again and everything worked. I notice that now I am using kernel 5.15.52-1.fc32. Perhaps it got updated during another system update which fixed the issue.

BTW now I notice that I attach the USB wifi adapter to sys-net, not to sys-usb, as stated initially. Attaching to sys-usb is not an option. (Doubting my own words) May I have been wrong in my initial message or has something else changed during system updates?