Why don't the network connect?

The network don’t connect to a router after the first install. You might want to fix that? What’s the issue? Thanks.

My psychic abilities are at an all time low, but my crystal ball tells
me that there is some problem with your sys-net.

It would be helpful if you were to say how you are trying to connect to
the router (wired or WiFi); what devices are allocated to sys-net (Look
in Settings, under the Devices tab); if you are able to start sys-net;
what template you are using for sys-net; if the log in sys-net shows any
errors relating to your network device (open a terminal in sys-net, run
journalctl -b and look for errors).

While you are doing that I will polish up my crystals.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.
1 Like

Thanks… Wired. And i used disposal net-vm. So it keeps loading mostly… As a default install. That could be an issue. Other linux dists just connects. i will look for that later. using wifi now because that worked, but i have to type the password at every boot.

OK - I dont know what " it keeps loading mostly" means. Are there any
errors/warning in log?
As to WiFi the reason for this is precisely because you are using a
If you dont want to do this, you can copy the credentials from your
disposable to the disposable template ( the qube that your sys-net is based on).
The credentials are in /etc/NetworkManager/system-connections.
If you do this then they will be available in every disposable that uses that
qube as template. If you dont want this, then you should create a new
disposable template for use by sys-net.

Or you can switch to using a non-disposable sys-net, for networks that
you connect to regularly, and keep the disposable for travelling.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

Gonna check later… thanks

I tried this recently, and i did get a connection symbol. I wanna connect to a router that has internet. So i changed to 192.168.x.x …
Lets say the router is at to access from the browser, how should i set up sys-net? ipv4. Thanks!

edit: I’m thinking like and ? In qubes…
In another dist, the connection happened automatically after i entered some details, and i had internet. Instead of wifi which i want to avoid, it’s better to use a cable and it’s more smooth overall.


Just to clarify for you (bmqbmhhslj): IF you’re using a disposable sys-net, you ALWAYS have to setup wireless “manually” - EVERYTIME !!!

If you knew this already, ignore my post! If not, then follow unmans tip to “use a non-disp sys-net” for "logged in wireless on every startup!

If you don’t want this and move on using a disp sys-net, you just have to right-click on the network symbol and choosing “available networks” from the menu - click on your wireless net and insert your wlan-key. Everytime on startup.

PRO: you never will have your wireless card crying around, when you’re on another place to setup for a wlan (airports, coffee shops, etc.) cause it’s always quiet "waiting for you to giving the correct ‘wireless lan’ and the ‘key’ for logging in…