Whonix WS Applications not Showing Up (after restore from backup)

Honestly, I don’t remember how it was before I restored my Whonix VMs (due to a crash I had to restore my old VMs). Now I have four templates:

  • Template: whonix-gw
  • Template: whonix-gw-15
  • Template: whonix-ws
  • Template: whonix-ws-15

Is this normal if yes why four instead of two (one workstation, one gateway)? Or can I just delete the VMs without numbers (like normal obsolete Template VMs)?

Hi @whoami,
there is the old-one and the new-one (restored) VM for each workstation and gateway, see the @Surf question and the @adw answer here.
I think the -15 is the new-one, but not sure, check before deleting!

Ok, I have removed the whonix-gw and the whonix-ws.

Now, I have

But know I cannot launch the tor browser in the disposable whonix VM. It is simple not available the Qubes VM launcher menu but selected in the VM settings, Applications.

I already tried Refresh Applications, restarted Qube…

Do you see any wrong setting in the screenshots?
Could you please compare with your default whonix installation.

Thank you

Hi @whoami,
did you try to launch the tor browser from a terminal (the command is torbrowser)? Just to check if it is present and works well… Then check the below documentations and report here which eventually failed:

I hope it will help you.

Hi @ludovic,
thanks for your help.

As you can see in my last screenshot this is not my issue. It is listed in my Applications list - so it is Available and it is Selected. But when I want to launch it over the “Q” it is not displayed.

Yes, this works. I can start a disposable VM - terminal and launch torbrowser.

I just updated the torbrowser (via the whonix template VM) and this pops up:

So, I am wondering if my backup somehow mixed up the settings of DispVM and TemplateBasedVM…

Could you please confirm that your Whonix settings looks like my screenshots (in my original post before)?

Hi @whomi,

Yes it’s same, except the Selected Applications which contains the default entries (chat Support, Thunar File Manager, Tor Browser (AnonDist), Tor Browser Downloader (AnonDist), WhonixCheck and Xfce Terminal).

Inside a dispvm instance, do you get the /usr/share/applications/janondisttorbrowser.desktop file?

user@host:~$ cat /usr/share/applications/janondisttorbrowser.desktop
## Copyright (C) 2012 - 2020 ENCRYPTED SUPPORT LP <adrelanos@riseup.net>
## See the file COPYING for copying conditions.

[Desktop Entry]
Exec=torbrowser %u
Name=Tor Browser (AnonDist)
GenericName=Privacy Browser
Comment=Start Tor Browser (AnonDist)
user@host:~$ dpkg -S /usr/share/applications/janondisttorbrowser.desktop
tb-starter: /usr/share/applications/janondisttorbrowser.desktop

If you don’t get the file, search in this direction.

Else, search how is build the menu entries in dom0, my menu entries:

[qadm@dom0 ~]$ find .local/ -name "whonix-ws-15-dvm-jan*.desktop"

[qadm@dom0 ~]$ cat .local/share/applications/whonix-ws-15-dvm-janondisttorbrowser.desktop
[Desktop Entry]
Name=whonix-ws-15-dvm: Tor Browser (AnonDist)
GenericName=whonix-ws-15-dvm: Privacy Browser
Comment=Start Tor Browser (AnonDist)
X-Qubes-NonDispvmExec=qvm-run -q -a --service -- whonix-ws-15-dvm qubes.StartApp+janondisttorbrowser
Exec=qvm-run -q -a --service --dispvm=whonix-ws-15-dvm -- qubes.StartApp+janondisttorbrowser

The two files get same content:

[qadm@dom0 ~]$ diff .local/share/qubes-appmenus/whonix-ws-15-dvm/apps/whonix-ws-15-dvm-janondisttorbrowser.desktop .local/share/applications/whonix-ws-15-dvm-janondisttorbrowser.desktop
[qadm@dom0 ~]$ 

If absent, you can add these files manually, but I think a Qubes command should be launch to rebuild your menu entries… Search in the documentation the required command, and if it works, give the solution here.

It found only:



I will delete the Disposable VM and follow this guide to make it new from sketch:

Keep you posted

I again double-checked all settings in:

and I could fix the issue by ensuring that all Qubes settings has started. Means in the Q (app launcher) of each VM:

and afterwards I forced a Application refresh: VM settings > Application > Refresh Applications

(@whoami I’ve changed the title to better match the discussion. Let me know if I missed something)

1 Like

Good point! Thank you
I just added “…(after restore from backup)”

1 Like