Whonix-WS-15 Tor Browser not updating

This is very probably a question for the Whonix maintainers, but I’ll ask here because it might be specific to the Qubes version (will delete if deemed inappropriate for this forum):

Why is Tor Browser not updating? It’s been out of date for weeks, and with the latest update, my Whonix dispVM has to download an 85 MB via Tor every time it starts. This is far from ideal. Is there something I’m missing?

Ideally when you update from DVM it should save the updates, looks like you are updating from DisposableVM ?

Lets look with the glossary :


A type of temporary app qube that self-destructs when its originating window closes. Each disposable is based on a disposable template.

See How to Use Dispoables.

  • Previously known as: DisposableVM , DispVM .

disposable template

Any app qube on which disposables are based. A disposable template shares its user directories (and, indirectly, the root filesystem of the regular template on which it is based) with all disposables based on it.

  • Not to be confused with the concept of a regular template that is itself disposable, which does not exist in Qubes OS.
  • Disposable templates must be app qubes. They cannot be regular templates.
  • Every disposable is based on a disposable template, which is in turn based on a regular template.
  • Unlike disposables, disposable templates have the persistence properties of normal app qubes.
  • Previously known as: DisposableVM Template , DVM Template , DVM .

I see what you’re saying, but that’s not the case here. I update as usual from the template, which is then reflected in the dispVM.

The problem is that there’s no update for the template (via the repos).

I don’t know, maybe they don’t have time, but still.

DispVM Template = AppVM

DispVM Template should have network it’s different with “regular” Template.

Did you try to update from the whonix-ws template by running “Tor Browser Downloader”?


Try running sudo update-torbrowser inside whonix-ws-15,

1 Like

This worked. No idea torbrowser had to be updated independently (not via apt upgrade or the built-in template update function). In the past, updating the template itself did the job, so this should be noted.

@fsflover’s non-CLI solution should’ve also worked, but I have a preference for CLI