VPN VM based on debian-10-minimal not working

VPN VM based on debian-10-minimal are not working. Has anybody tried this recently?

If your on 4.1 testing then yeah, no debian based VM are able to “Provide network” to other qubes.

Yup, on 4.1.
sys-net, sys-firewall are also debian-minimal based and they are working.
Template for VPN VM contains debian-minimal and following-

Am I missing something Package wise?

I can’t speak for -minimal templates, but since I enabled
“buster-testing” repo and updated with that, my Debian VMs have been
working fine with openvpn and “provides network”.

I am on testing version too. Not worked for me yet. Switched to fedora for time being and will try later if it gets resolved.

I know this is old and there is a lot of recent writing on deb-10-min config - but the simple recipe for minimal upgrade to current deb-10-min to run @tasker’s VPN scripts (in R4.0) is:
apt install qubes-core-agent-networking openvpn libnotify-bin

[ed: there is no notify daemon, so you don’t get them, that is what I prefer since I run lots in parallel and notifications are of limited use without a timestamp and one is showered with them when your internet goes down. The VPN scripts will error exit without notify-send.]


Exactly. This is the same issue as