Various- freezes , Award Uefi suggested, Whx time complaint

hello, so installed and have been using rc1, without major issues, except mouse pointer won’t resize, this is on an Intel i5 integrated video, desktop. 32G Ram, SSD, etc.
I’ll just list the issues, (sorry I didn’t search other than the summary 1st few 4.1 pages, nor the github).
1)
with whonix there is a a popup that appears then fades about “swdate” despite the swdate being correct, not sure on the behaviour that makes it appear, likely with the template -ws updates

I would like my monitors to sleep then turn off when not being used but have never been clear on which takes priority the xscreensaver “blank after” “cycle after” or the Xfce Power Manager display → “blank after” etc; for now I’ve set the latter to “never” ; and for Xscreensaver Mode: disable screen saver; and am just using the buttons on the monitors;
I am doing this because lately the monitors turn off, and can’t be reawakened, so I’ve had to hard reboot ; *However,

  1. I’ve also been getting hard lockups of the whole system; I’d be happy to supply any logs if I knew what to look for or post, this has happened 3 times (2 while monitors were On recently); *But I’m thinking this might also be why the monitors didn’t reawaken??

…hence for now I’ve been playing with the Award UEFI, I notice that PCIe for graphics was enabled though, mine are integrated, so changed that (though it has never been touched through all my 4.0.1 use.
…so called speed-step I’ve engaged and disengaged seems to freeze regardless, for now its disengaged, and also disengaged “turbo boost”

  1. so I’m wondering is there any official suggested Uefi setup for major Uefi makers ; instead of the guesswork, (I am aware of the documentation that says this would be too difficult, nonetheless) ; even a small something eg speedstep, turbo reports might be nice.

  2. I’ve maxed out my CPU and case fans for now; I do see something in $sudo dmesg

Nov 10 19:51:51 dom0 qui-updates[9380]: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

then a 100 of these

Nov 10 20:19:20 dom0 qrexec-policy-daemon[5301]: qrexec: whonix.SdwdateStatus+: sys-whonix -> disp6685: allowed to disp6685

which I guess are just pings for the utility, they end about 830pm, then there are no more overnight;

maybe time to disable sys-whonix or go to rc1 - testing repo?

See Monitor DPMS power-saving not working · Issue #3590 · QubesOS/qubes-issues · GitHub and lock screen does not turn off backlight while active (nouveau/ThinkPad P52) · Issue #5000 · QubesOS/qubes-issues · GitHub.

It should appear with journalctl command in dom0 (have a look at its flags to find the related line in its output).

Issue #3590 is marked solved for $4.0-rc4

Qubes OS version:

R4.0-rc4
Steps to reproduce the behavior:

In xfce4-power-manager-settings adjust the display to suspend and/or power off after a set time, then wait.
Expected behavior:

As with R3.2, monitor goes into standby/suspend/low power mode.
Actual behavior:

Monitor display is blanked, but remains fully powered-on.
General notes:

This may be related to the fact that I used KDE on R3.2, and now I use Xfce on R4.0.

then there is one comment, below solved, saying

Old issue maybe but I have the same problem in 4.1-rc1. It was working on 4.0.4. I did a reinstall to 4.1 and not an in-place upgrade. Did try on a second computer, same thing.

my system is also a fresh reinstall to rc1 fwiw.

but not sure this explains the lockups while monitor is on, which I think is also happening whilst the monitors blank (or were blanking before I’ve attempted to just use monitor buttons)

ironically, system froze-locked up again right after posting that message,
sudo journalctrl -r does have a few highlighted Red postings, but no idea if they are relevant or not eg

libvirtd[6862]: internal error: Unable to reset PCI device 0000:00:14.0: no FLR, PM reset or bus reset available
Nov 11 0 dom0 pulseaudio[12599]: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Nov 11 0 dom0 pulseaudio[12599]: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Nov 11 0dom0 pulseaudio[12599]: ALSA woke us up to write new data to the device, but there was actually nothing to write.

PS: just noticed the qubes manager allows one to change template without open the settings now, very nice !

I am a bit suspicious of Signal, its my only non-debian install, and apparently like the rest of the world does the rolling-release, often the only update I ever get in my templates, going to change to non-signal template …

…redacted