USB printer on Debian 11

I have attached my USB printer (epson wf-110) to an app VM (debian 11), but the printer is not detected when I click Add Printer in Settings. The only one that shows up is the CUPS printer.

I tried opening localhost:631/admin, but I don’t know the username and password. I tried root and root, but it didn’t work.

The last time I needed to print was on fedora 34 and it worked.

Did you install epson driver in debian template?

I did run sudo apt install printer-driver-all on the template, but it didn’t help.

I just downloaded the .deb file for the printer from epson. But on the download page, it says LSB must be installed beforehand. When I tried to install that, it said the package is not available, but is referred to by another package…
E: Package ‘lsb’ has no installation candidate.

Yes I found that page, too. Installing alien will download another 215 mb of packages! I don’t want to put all of those on the template for a printer.

I tried the lsb-compat but it did not work, the epson driver is still complaining there is no lsb.

Maybe you don’t need to install alien in your printer template. You can try to install alien in disposable, convert rpm to deb in disposable, then copy this deb in your printer template and install just this converted deb there.

Good idea, and I just tried it, but the newly created deb file errored out on the template. It said:

N: Download is performed unsandboxed as root as file ‘/home/user/redhat-lsb_4.1-61_amd64.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Permission denied)

And still only the default cups printer appears.

This is not an error. The “N:” at the beginning says that this is just a notice. There is nothing to fix, (almost) everything worked as expected.

Even when apt is run as root, it tries to download packages as a separate user _apt. It does that to increase security. To download packages, it has to interact with a potentially malicious server and it has to download and process data from that server. Such situations are one of the main cases in which there are vulnerabilities. So if there was a vulnerability in that part of apt’s code, and if apt was running that code as root, the attacker could potentially run code on your system as root, i.e. they would have full control over your system. So apt runs this code as a user that’s very restricted in what it is allowed to do.

Apt also tries to do that when it fetches package files not from a remote server but from somewhere in the local filesystem. In your case, it tried to use the _apt user to access /home/bestuser/Downloads/discord-0.0.17.deb. But that fails, because the _apt user isn’t allowed to access your home directory. So apt instead accesss that file as root and it informs you about that.

In this situation (fetchting the package file locally) there’s no security advantage in using the _apt user, so using root isn’t problematic.

There’s nothing to fix, you don’t have to do anything.

Ok, but still it didn’t work. Only the cups printer appears in the list, even tho the Epson printer is attached to the VM.

Could another person try it to see if they can make it work?

Did you install deb package with your printer driver from epson site after installing lsb?

Ok, yes I forgot to try to install the Epson driver again. Still, it failed:

The following packages have unmet dependencies:
epson-inkjet-printer-escpr:i386 : Depends: lsb:i386 (>= 3.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

I guess you’ll need to find i386 lsb rpm package instead of amd64 one and try to install in instead.

I have given up, need to get to other things today. Hopefully someone with greater skills can get it to work. I’ll check back here later. Thank you for your help.

You can try the i686 package from here:

[deleted…was asking if you had attached the device with qvm-usb attach or the qui-devices gui…but then I looked again and saw that you said you had.]