Updating Whonix fails with 404

I’m very new to Qubes and Whonix, so forgive me if that’s an obvious one.
I installed Qubes 4.0.4 today and selected the option “Enabling system and template updates over the Tor anonymity network using Whonix”.
Once I started the first time (and logged into my WIFI) I got the hint that updates are available. Some updates installed successfully, but whonix-gw-15 and whonix-ws-15 didn’t (and don’t). The update fedora-32 states that it installed successfully, but it appears every time as ready to update, so that’s probably not working properly either.
The error message for the whonix templates states that the apt repositories can’t be reached (the function pkg.uptodate fails with error messages Failed to fetch tor+http://<...>.deb 404 Not Found [IP: ...]). I already tried updating the template manually with apt or using the update tool in the Qube Manager, but I get the same error everywhere. I also tried adjusting the repository files to use Onion services (before, clearnet services were used), which didn’t help.

Please let me know how to supply you with additional information, if necessary.
Thank you for your help.

I’m sorry your Qubes journey has started with a problem.
The version of Whonix that came with 4.0.4 ids outdated, and has been
replaced with Whonix-16.
Rather than update Whonix-15 you should install Whonix-16 -
instructions are here

Fedora-32 is out of date, and you should install the latest template.

A new version of 4.0 is in the pipeline which will have the latest
versions of all templates and packages from the off.