Unable to attach SD Card to AppVM

Hello I am having difficulty attaching an SD Card through a USB card reader to an AppVM. It is a 16GB card. I can get the sys-usb to recognize it, but could not get any of the AppVMs to recognize it. I had no problems getting an App VM to recognize a USB stick however.

My understanding, it depends on the format.

Does it pop up as

  • sys-usb:sdx with a sys-usb:sdxN just below or

  • is it listed as sys-usb:Y-Y.Y

x: letters a, b, c…
Y: numbers 1, 2, 3 …

If it is a Y-Y.Y it should be listed in the VM Files app menu (on the left)
If it is a sdx make sure you attach the sdx (not the sdxY) and afterwards you should find it in the VM Files app > Other location

I have had issues like this when using certain MS formatted sdcards. exFAT vs FAT32 comes to mind. Make sure your templates have the necessary drivers to read what you are passing to your AppVM.

It is listed as numbers: sys-usb: 2-4.3 and it does not show up in the VM Files app menu.

I tried different SD cards. One 16gb was recognized by sys-usb and the other 16gb was not. My 64gb was not recognized either.

If you do not have any data on it try reformating the SD card.
You can also test a usb-adapter (if you have one) to have it recognized as usb stick.

I do use a usb adapter.

Just tried an experiment. I have Qubes on both a desktop and laptop. The laptop has a built-in SD-card reader. I had no problems attaching the card to an App-VM. However when I used a usb-adapter with the sd card I couldn’t attach it to an App-VM.

So maybe as @slcoleman wrote before a driver issue.