Unable to add Qubes extension to Thunderbird in Fedora Minimal

I have been using Qubes for a year. I recently opted to using Fedora Minima as the main work VM. However, I have failed to install the Qubes Attachments extension to Thunderbird that allows for Qubes actions for attachments like “Open in DVM” or “Send to VM”. I tried dnf install qubes-thunderbird but the response is “Unable to find match.” I also installed pycairo as per recommendations on some forums. It installed but without success in installing the extension. Any suggestions?

Try thunderbird-qubes instead.

Thank you! It worked! You need to update this page that says qubes-thunderbird instead of thunderbird-qubes https://www.qubes-os.org/doc/templates/minimal/

Well, I’ve noticed that it’s thunderbird-qubes for Fedora and qubes-thunderbird for Debian, so one of the package names might be mistaken. I’ve opened an issue about it:

I’ve updated it, but in case you (or any others reading this) are not already aware, the documentation is a community effort, and everyone is welcome to contribute. (That’s how things like this often get updated!) So, if you’d like to get more involved with the project, doc contributions a great way to do it. You can read more about how to submit documentation changes here:

1 Like

Thank you. I will explore how to contribute. But as someone who needs Qubes but I am not an IT person, I admit that GitHub is intimidating.

@oijawyuh, ignore that it’s github. It’s an website where all you have to is create an account on and click three buttons to contribute (after the first time it’s only two).

When editing you can also click on “Preview Changes” to visualize the final result.

That’s it! Good luck :slight_smile:
And you can always ask for help if something unexpected arises

Thank you for your recommendations. Much appreciated.
Now after the last Thunderbird update, Qubes Attachment version 2.0.5 dated October 15 is not working anymore. Should I just wait for an update or is there something wrong with my setup? I have a 2-year old laptop with 16GB RAM, and minimal amount of VMs running when doing a video call.


yes unfortunately this is a known problem with the newest version of Thunderbird:

until it gets updated, you can always:

  1. Save the attachment in your email VM.
  2. Right-click on the attachment and select “View in DisposableVM.”
1 Like

I’ve noticed a similar issue. However, I looked at the add-ons within Thunderbird, and qubes-attachement is no longer available for any version of Thunderbird.

Another alternative appears to be Qrexec: secure communication across domains | Qubes OS however, it’s a bit challenging.

Could the qubes attachment add-on be updated to include the following features?

  • open file in VM
  • send file to VM
  • and open hyperlink in dspVM