Tuxedo InfinityBook Pro 14 Gen 6

I hope this questions belongs here.

How did you do


I’m considering to buy this device but can’t find an instruction that tells me how to do that.


I found this solution here in the forum: How to add custom kernel options in v4.1?

Is this also the way you did it?

  • Edit the file /etc/default/grub .
  • Find the line which starts:
  • After quiet add i915.enable_psr=0 and save file

  • Run this command in dom0:

 sudo grub2-mkconfig --output=/boot/grub2/grub.cfg
  • Reboot


The default installation image for Qubes 4.1.0 works for me, but the fix for the flickering by @enmus does not work for me.

What else can I try to fix the flickering? It happens whenever I move the mouse.

This is not a good place to ask for a help on the issue.

It would be better if you’d create separate topic or searched the forum.

I have also the flickering issue. I found here solutions: add i915.enable_psr=0 as kernel parameter and here: [ xfwm4…] (Flickering screen after 4.1 update - #8 by kindasecure)

Neither helped for me.

Here my HCL Report (cant upload).

Any idea?

brand: |
model: |
TUXEDO InfinityBook Pro 14 Gen6
bios: |
cpu: |
11th Gen Intel(R) Core™ i5-11300H @ 3.10GHz
cpu-short: |
chipset: |
Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers [8086:9a14] (rev 01)
chipset-short: |
gpu: |
Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
gpu-short: |
network: |
Intel Corporation Wi-Fi 6 AX201 (rev 20)
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |

1 Like

Welcome to the qubes forum!

mh… dunno how the driver situation for your gpu is.

what is the output of:

sudo glxinfo | grep Accelerated in your dom0?
What kernelmodule is active at lspci -v | grep --after-context 25 VGA?

1 Like

Moved to HCL reports @Sven

1 Like

Accelerated: yes
Kernel driver in use: i915

Should i post the whole text?

That looks good, so you have the driver and it seems to work.

Unfortunately i am not sure what to try next.

Maybe switching out the compositor and/or try some vsync related settings? Somebody else tried that compton (other compositor) without it helping.

I am not sure that this is a strictly qubes related issue, so maybe also try to look for “xfce4 flickering” for other distros.

Sorry i could not help more :confused:

Thanks, I try…

A played a little bit.

Compositor off doesnt help.

I have found that with an external monitor it works. it concerns the internal display (3k).

The “vsync related settings”. I dont know where an how. But i will search for it.

I recently switched to compton and saw that there are some settings for that there.

That is interesting!

Have you tried to reduce the resolution to FHD just to see if this happens then too or play with refresh rates?

Yes i did. That makes no difference

I tried also this, but no effect: TearFree

1 Like

Now I have a track.

There is also a help from the manufacturer of laptop. the result of last command made me wonder.
The 'i915.enable_psr=0’ parameter is not showing!?

Maybe the grub update command is not correct. Stepp by step:

sudo nano /etc/default/grub => Ok and saved

GRUB_CMDLINE_LINUX_DEFAULT= => I dont have such a command line
Only have one line: GRUB_CMDLINE_LINUX="…" and another line: GRUB_CMDLINE_XEN_DEFAULT="…" and another line: GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX …"

I tried each of the three variants with the i915 parameter. But the result of cat /proc/cmdline command doesn’t contain i915.enable_psr=0.

Is the command cat /proc/cmdline wrong or ist the grub update command wrong? I tried all:

sudo update-grub => not working because of grub2 i think

sudo grub2-mkconfig --output=/boot/grub2/grub.cfg => done

sudo grub2-mkconfig -o /boot/grub2/grub.cfg => done

sudo grub2-mkconfig -o /etc/grub2-efi.cfg UEFI new?

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg UEFI old?

sudo grub2-mkconfig -o /etc/grub2.cfg ?


I am a little bit confused now. I think a have UEFI.

But never the result of cat /proc/cmdline command doesn’t contain i915.enable_psr=0.

(Qubes R4.1 / Fedora 34)

Ok, I found this. I dont understand the change from Fedora 33 to 34 really.

sudo nano /etc/default/grub => to edit and save Ok.

=> sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg => to refrain

=> sudo grub2-mkconfig -o /etc/grub2-efi.cfg => from Fedora 34 ?

or => sudo grub2-mkconfig -o /boot/grub2/grub.cfg

1 Like

Ok, the question is now: How can i update grub.


The sudo grub2-mkconfig -o /boot/grub2/grub.cfg ignore the i915 parameter.

This is the ´sudo nano /etc/default/grub`

GRUB_DISTRIBUTOR="$(sed ‘s, release .*$,g’ /etc/system-release)"
GRUB_SAVEDEFAULT=true <= i added this, tried it also without this line
GRUB_DISABLE_SUBMENU=false <= this was before true, tried it also true
GRUB_CMDLINE_LINUX=“rd.lvm.lv=qubes_dom0/root rd.lvm.lv=qubes_dom0/swap plymouth.ignore-serial-consoles rd.driver.pre=btrfs rhgb quiet i915.enable_psr=0
GRUB_CMDLINE_XEN_DEFAULT=“console=none dom0_mem=min:1024M dom0_mem=max:4096M ucode=scan smt=off gnttab_max_frames=2048 gnttab_max_maptrack_frames=4096”

And this the output of cat /proc/cmdline

placeholder root=/dev/mapper/qubes_dom0-root ro rd.lvm.lv=qubes_dom0/root rd.lvm.lv=qubes_dom0/swap plymouth.ignore-serial-consoles rd.driver.pre=btrfs rhgb quiet rd.qubes.hide_all_usb

Hi @steff I moved your post into the respective thread for that machine. In this category we aim to have one thread per model so all of the relevant discussion is in one place. (/CC @fsflover … thanks!)

1 Like

This topic is walked “All Around the Qubes”, hahahah

First try if the parameter is even available for your gpu:

$ modinfo i915 | grep ‘^parm:’

If yes, then try to put it after the word “consoles”.

Give us

$ sudo journalctl -g i915

After that, I’m out of ideas.

Maybe @51lieal could help.

The same model of on my laptop, I use 5.10.104-3.fc32.qubes.x86_64 qubes4.1. From time to time I get black screen, fan spins and nothing happens. I presume it can be like that forever so after a 10 min I turn it off. Sometimes next boot is correct sometimes not. It is completely random issue. I don’t have an idea how to investigate this issue. Such issue can derail any conference meeting.