Trying to update Bios via Pendrive

Hello Qubes community,

I want to do a Bios update with FreeDOS, i used cfdisk and created a partition as you can see:

I feel completely stupid. I installed the FreeDOS Lite Usb version on my sd card, i do not know if this is the right way and image to do but i tried(nothing shows up in Boot manager in legacy mode), it does not work. I installed it via DD onto the sdxc card(installed it to /dev/xvdi1). File manager prints out a different device

If i detach the sd card via device manager it prints out that:


This confuses me entirely. I also partitioned and selected the Ms95 FAT32 (LBA) table before i DDd the DOS image to the blck xvdi1 with:
sudo dd bs=1M if=FD12LITE.img of=/dev/xvdi1

Also maybe someone can explain to me what that listed usb device "sys-usb: 2-5 - 04ca_3015 in the Dom0 terminal on the left downside in the screenshot is? Is this for USB-Passthrough?

Also it seems to me that i found a bug if this behaviour is not expected or the filesystem doesn’t stores something in the tmp.
If i detach the sd card via device manager in the gui and try to open the FD-Setup entry of the (excepted blck device from Sd Card) in the File Manager i’m able to open it even if i detached it before via Device Manager. I closed the File Manager Windows and opened it again multiple times but the entry stayed and worked. Only if i detached the device in the filemanager itself it goes away.

Please dont laugh at me, i basically lack fundamental experience in Linux. But i thought starting with qubes would be a nice starting, because you learn more and have to fiddle around very much and try things out. And you can delete Vms entirely if you feel uncomfortable what you as a beginner bungled around in a VM…


Some machines cannot boot from the SD card reader. Could this be the case here?

I thought about that to. Maybe i try it out on another PC. My InsydeH20 bios from Acer looks like from a Kindergarden, i even cannot disable hyperthreading by default.

But one or two weeks before(and im not schizophrenic) every single uefi function was there, i do not know if this was a bug or a accidentally secret keystroke that i hit but that scared the fuck out of me.

Bios Backflash mode under the “Debug” that listed magically up was magically there under the cards in the overhead of the Interface, Security card listed up, i was even able to set the write protection locks from ME or SMM on or off! (in the UI of the Bios !!!) … also i seen Platform Control Hub card in the overhead and i was also able to overclock the Skylake CPU in the Bios! (of course not multiplicator but the other settings)…

I rebooted, everything vanished. PC turned from legacy mode in uefi mode and booted to windows 10 from itself before one time. My bios version is the oldest version. V1.12

I really like to nuke the soic of my bios with the newest software. But it seems if this all is true that it is completely gameover?
Is the excepted UEFI/SMM/PCH-Rootkit able to install malware to the sda drives or a bootkit and escalating from uefi to the grub bootloader as example?