Trezor-Guide seemingly bricked(?) my window manager

Hello, like the title says i tried setting up the trezor-software, but it somehow bricked my windowmanager. After following the guides here on the forum, i used my pc for a while and later made a restart. The trezor worked, but the window manager doesnt start anymore.
It shows itself that the outer ‘QubesOS-windows’ arent showing, they’re stacked up in the left upper corner and i can’t move them. I can somehow circumvent it by running the command ‘xfwm4’ in dom0. My first idea was to revert any changes made, but that didn’t help. Are there any logs that i could consult to see whats wrong?

I really hope i can avoid doing a new install.

what guide did you follow?
what did you do exactly on your system?

1 Like

I used this guide: Ultimate Guide on Using Trezor on Qubes

Instead of a whonix AppVM, i used a fedora based AppVM.

I already deleted the file created in dom0 under the second step.

Another thing i did was the suggestion from the Whonix docs to try a separate HVM persistent Qube. One controller threw me the ‘couldnt reset device’-error, so i forced the reset via the Qubes Manager GUI under Qube Settings→Devices→bottom.

Author of the guide here. Could you elaborate on what exactly you mean by window manager? Can you also post a screenshot of the issue?

I only just skimmed that guide and have never tried it myself, but the only place where I saw anything happening in dom0 is adding a one-line, Trezor-specific RPC policy file. If this is correct, then there should be no possible way for any steps in this guide to mess with your window manager, which is controlled by dom0. It sounds like you might have misread the instructions and accidentally executed a bunch of the steps in dom0 instead of a domU, but this is just a guess.

Another possibility is that it’s a coincidence, and the problem is unrelated to the Trezor stuff. Have you made any other changes in dom0 recently, such as changing or customizing or desktop environment or window manager?

1 Like

@Ursidae I sadly cant anymore as i did a new install, but it was basically that the ‘Qubes’-titlebar wasnt appearing, all windows tiled up in the top left corner and i couldn’t change focus. I had to enter ‘xfwm4’ in the dom0 terminal that it kinda went back to normal.

@adw I didn’t. the only thing i did was to make a policy file to change the update-vms.