TorBrowser without Tor on Debian template with tb-updater - where to put user.js?

I’m trying to setup Tor-browser without Tor in a Debian template. This template (i.e. its Appvms) should never host any Tor activity.

I’m trying to implement instructions at Whonix, but using a tb-updater installation because I understand it works better with Qubes’ templates system.

The instructions call for a manual install of the browser, then lays out* how to create:

But I don’t have that path, nor anything like it. No ~/.tb even. Really, all I have is:

  • /usr/share/torbrowser/
    • security-slider-highest.js
  • usr/bin/torbrowser/
    • torbrowser

I tried extrapolating from Firefox examples, but they too have long multilevel paths to profiles and user.js. I am assuming this difference stems from adaptations to templates/Appvm structure?

In any case, where do I put the user.js file?

* I can only link twice in a post at the moment. Append #cite_ref-12 to the Whonix URL above.

usually a very quick and easy wa to check such things is well fairly simple
clone you’re vm (allways for backup anyway when you’re modifying stuff and don’t want to mess up)
try one way and try another
see whichever works…

(i mean it depends usually it’s much faster to do then to look into all the doc’s)

Thanks, I appreciate what you’re saying but I have an absolute requirement to not run Tor from that template/decendent-vms. I don’t want to experiment like that.

(Yes, learnt the value of backup the hard way…)

This may be better addressed in the Whonix Forum (if it hasn’t been already!):

I can’t. Patrick closed the question down without an answer, just a link to “Secbrowser is deprecated”.

Granted, I knew less about what I was asking and formulated it really badly and confusedly, but I don’t think he welcomes the question.

Look, this is a Qubes issue.

Secbrowser had a lot of fans here, and its deprecation was ‘advertised’ here.

Secbrowser has no replacement except tor-disabled tor-browser.

The instructions at Whonix talk about a manual installation. Their Qubes-relevant instructions are for Whonix templates. (edit: my question isn’t addressed at the Whonix forum).

tb-updater is presented as the most Qubes-compatible way to get an efficient installation of torbrowser into a template. But it renders the Whonix instructions for non-tor torbrowser inoperable.

I can’t be the only Qubes user wishing for a Secbrowser replacement, trying to get this to work within the Qubes-template framework.

1 Like

It really isnt a Qubes issue, although it may be of value to some people
who use Qubes.
It might help if you were to explain what Secbrowser offered that made
you a fan, and why a tor-disabled tor-browser isnt a good replacement.

imo the best thing to do is to mod your firefox with arkenfox user.js,
which is well documented, and add the standard Tor Browser extensions -
HTTPS Everywhere,NoScript. Add a canvas hasher, and it will be better
than Tor Browser.

Secbrowser offered excellent fingerprinting resistance. I trusted “the brand”. I liked the slider. Updating for DispVm copies was sometimes a pain.

No, it is a good replacement. That’s why I’m trying to use it. But the instructions are based on a manual installation with a different filestructure than tb-updater gives.

tb-updater provides better compatibility with Qubes’ templates than manual installation. From tb-updater:

Qubes integration:

  • Up-to-date browser versions made available to freshly created AppVMs and DispVMs.
  • In DispVM mounts browser folder which resides in root image to user home folder rather than copying for faster browser startup.

(Qubes project people on that dev list, too).

Maybe my question should be broader: where do you put user.js files so the Qubes-specialized version of torbrowser will use them?

When I tried a few weeks ago, Secbrowser beat arkenfox on Even now with a deprecated copy, Secbrowser gets “not unique”.

However, I might have another try with your suggestions of addons [edit: and arkenfox and Firefox]. Looks like its just easier.

See if this helps: (it’s an answer for a question I asked a while ago on whonix tbb customtization)

Patrick got back to me, also. My system just was not generating ~/.tb... where it should have.

I had apt purged secbrowser, but was still finding files. Turns out another secbrowser installation was lurking in /var/cache. So tb-starter or torbrowser (everything “tor” is getting blurred) installs to ‘/var/cache’. I didn’t and still do not fully understand that this is what that means

In Qubes AppVM copies browser from root image to private image at first start.
Git page

grepped for tb-browser and found it in there, installed .tb in there, hidden to me. Whonix forum thread.

This my third edit of this and the other post - I still don’t get this no ~/.tb. Instead:

$ bash x torbrowser


In case I’ve made other mistakes, I’m going to make a new Debian template and work from there.

Thanks again

1 Like