Tips for using a Webcam?


I am currently trying to use a USB Logitech webcam (I’ve tried multiple models) but I am running into issues. I am using a desktop computer that is custom built. Wondering what webcams people have used that work with Qubes? I’m also not sure if it’s the webcam or the USB controllers on the motherboard. Advice here would be appreciated!

Here’s the github issue that I’ve described my issue in as well:

Here’s a related discussion on the issue:

Mainly looking for a workaround until the main issue is resolved, not trying to start another thread to discuss the same issues as above.

I love Qubes, but not being able to use a Webcam on video calls for work is the only thing holding me back currently from switching to it full-time.


On another webcam issue discussion the solution was to increase the ram of sys-usb from 300MB to 1024MB (on the Qube Settings » Advanced » Initial Memory). Maybe that helps:

1 Like

the linked gist might be a solution that helps you, or the one in the original issue

1 Like

@deeplow Thanks for pointing that out. That worked to get the camera to be steadily connected to the AppVM and works with cheese. However, the camera is still not detected by Zoom, Chrome, or Firefox.

1 Like


This issue does not seem to be related to Qubes itself but rather the TemplateVM you’re using (Debian or Fedora). If you’re on Debian, try switching the template to Fedora and vice-versa. (any help, just ask)

edit: just saw your comment on github (“Doesn’t work on Fedora 32, 33 or Debian.”). So disregard this last part. My only other suggestion would be for you to try installing debian on a USB stick and booting from it to see if it works there (if it does it’s Qubes’ fault if not it’s probably hardware icompatibility with linux in general).

@deeplow So, it’s software related at this point. Got the camera working on Chrome and Firefox in both Debian and Fedora, but still not Zoom… So probably not Qubes related and marked this thread as solved. Thanks for the help.


I remember that a friend tried Zoom on Ubuntu with a Logitech webcam. While the browser-based version did not work, an unofficial Zoom snap package did.

If you are willing to go down that rabbit hole, make sure that the snap’s app confinement settings allow access to your webcam.

1 Like