Third party software in Qubes

I have been playing with installing Mullvad VPN GUI in a Qube. Maybe it is playing with me.

The GUI for Mullvad VPN will download in a Qube. The Software handler will install it. The GUI seems to work well. Although I don’t know how to perform a security audit on this, and did not try.

Problem is, that when I reboot the computer. The GUI for Mullvad disappears. Whereas the software which is native to the Qubes Software group - stays. Those software programs - are perpetuated, are still available after a reboot.

How can I keep the Mullvad I have installed?

Where is the best place to put the GUI? sys-net? sys-firewall?

Thanks for reading this.

Hi @catacombs,

I sounds like you’re installing the software in an AppVM. The documentation page about installing software males
mention of that case:

When you wish to install software in Qubes OS, you should generally install it in a template.

There may be other pages that explain the mechanism by which some changes you make in an AppVM are reverted upon restart, but the page about installing software is probably a good start:

(I have moved this topic to the Support category. It is perfectly on topic for the Qubes OS forum, and more people will see it in a category that is not restricted :slightly_smiling_face:)

1 Like

I have already tried to use a Template, well a clone of a Template. I had to violate the rule of never putting a Template online, as the note says, for security reasons. Mullvad VPN GUI also disappears.

I also tried to put it in the sys-firewall, which - well I messed up being able to get online until I deleted those efforts. (I used a pointer back to a Template for Fedora-37) I tried sys-net, also Mullvad Gui disappeared.

I realize the developers have made a good decision for them, to not fool with third party software installs being in the basic OS, because it requires a lot of time, and the third party software update might reveal a new security hole. Not to mention, any company might become compromised, and the Qubes Developers only want to create an ISO which is truly trustworthy.

But, this would be an easier solution for this one VPN to be installed and used than the current ways of installing Mullvad VPN.

While we are on the subject. I read everyone in the VPN business sings the praises of Wireguard as a VPN protocol, versus OpenVPN. Wireguard, less code, faster. I see notes saying that Open VPN has some security advantages. A contradiction??

I don’t have specific insight into instslling Mullvad in particular, however, as you say, I have seen mentions of several different ways people set it up in Qubes OS.

You’ve been following instructions provided by Mullvad (that seems very reasonable to me). It may be worth comparing them to other methods used by folks on this forum?

Again, I don’t want to point you in any specific direction because I don’t know enough to recommend any particular method over another, but I’d suggest taking (another) look through the results of a search for “Mullvad” :slightly_smiling_face:

A comparison of OpenVPN and Wireguard is unlikely to be specific to Qubes OS, and this forum is probably not the best place for it. That being said, you might find some pointers in the All around Qubes category, for example I see the question of preverence for OpenVPN or Wireguard came up in the following thread. (I’m not sure if a detailed comparison was performed, but it may be worth a read?)

I have used the Graphical User Interface of Mullvad App on other Linux distros, far more easier to install than the methods described for Qubes. The Graphical User Interface of Mullvad is far easier to use than the other methods.

I have used other VPNs with command line, interesting. Incredible frustrating when they did not function.

One of my interests is not to just make using a VPN more easy for me. I want an environment for the -not so computer experienced- to be able to quickly use Qubes and safely. Human Rights Defenders. Journalists, and the true market for Qubes, businessmen. Businessmen, I believe will provide the money for Qubes development.

These groups may not have much in the way of computer, or Linux expertise. They may not have a lot of patience for learning. They will want an Operating System environment to take them by the hand and lead them along. In the case of Human Rights defenders, I don’t see them with a lot of time to sit online to web addresses that talk about security. Web Pages for learning about computer security.

The first thing they need is to be able to install a VPN to get outside their own country.

For those who have already purchased Mullvad. Perhaps they could experiment with installing Mullvad VPN App, using a cloned Qube of a Template. See how easy it is to use. Or Not. And give us a vote on whether to pursue looking at putting in the Mullvad App, somewhere in Qubes. Not just the VPN, but the easy to install/use GUI App.

I hear you @catacombs, and I’ve no doubt so do the Qubes team and other folks in the forum!

I don’t use Mullvad, but ProtonVPN is probably very similar.

I made a sys-vpn qube that provides networking, and in that qube I installed the GUI client. The template is a clone of the sys-net template.

1 Like

According to Install Mullvad app on Linux - Guides | Mullvad VPN , installing mullvad VPN should be as simple as installing any regular APP, like onlyoffice.

I downloaded the deb, installed it into one template, then created an AppVM based on that template, added “Mullvad VPN” to its App Shortcuts, and Mullvad VPN happily started from the application menu in the AppVM. I cannot see why there should be a chance it wont survive across reboots.

If there is any way for me to follow those same instructions and for them -not- to work. I can be counted on to do that.

I spent some time attempting to use CLI to install. I had problems with the copy and paste. Then tried to type in the commands, where my keyboard presented the backslash key \ (I am not in Qubes now) and gave me a ‘less than sign’ <. I presumed there might be something wrong with the laptop keyboard, and plugged in a USB keyboard. Same problem. so it is mapping of keyboard. Since I had already used up over thirty minutes attempting this method. I stopped. I had other things to do in the last several days.

One of the reasons I put this in 'All around Qubes;"

Discussions relevant but not specific to Qubes (security, privacy, software freedom, system administration

was not that I could not figure out how to install some method of installing Mullvad, but that I wanted an easy, quick install method to install the easy to use the Mullvad GUI.

If a business person is giving Qubes a try to consider for his daily machine; If he was not a CS major. He gave up considering using Qubes when he spent thirty minutes reading suggestions and instructions on a much needed (for business reasons) feature (A VPN. A secure tunnel through the Internet) and went back to another operating system.

One of the guys in the local computer shop once said, “Linux is a good hobby. There is always something else that needs fixing, solving, trying to get to work. Nothing is ever really finished.”

Please give it a restart and tell us that the Mullvad GUI app survived the restart. I will have to spend an hour or two figuring out how to remap the keyboard. and whatever is wrong with my pasting into the terminal, with the hardware I have. I can paste the correct text into the Text Editor. But not the Terminal.

Surely reasonable as why these things happen, and easy how to solve when I read enough documentation.

One of my pieces of health care equipment is broken, and will likely take up all of today’s time. Maybe tomorrow.

Make sys-vpn and run on startup than configure your VM to the sys-vpn