Thinkpad X13 Gen3 12-th Intel

x4 thinner than x230
12-core cpu (nproc 16)
16gb ram
super portable
my advice if you can - just buy a 32GB ram model (ram is soldered)
I use Qubes 4.1.1-2 and kernel latest 6+ on btrfs
AX211 works great, no glitches, Qubes works superfast
TIP : just attached a LTE sim card and updated kernel everywhere

Qubes-HCL-LENOVO-21BNA002CD-20230215-181811.yml (713 Bytes)


Thank you @fuel_can for your HCL report, which is online now!

Allso latest kernel not enought.
Sound stop working - but easy to fix.
options snd_sof sof_debug=128

and suspend fix - uefi power settings- Linux S3

I have an X1 carbon 10th gen with Intel 12th gen CPU and cannot get suspend working, even with Linux S3 set in the BIOS. Might need to switch models!

Hi, BenT.
What happened when your laptop is going to sleep?

# echo mem > /sys/power/state ; dmesg > dmesg_after
doesn’t great a dmesg_after file so rather than a graphics problem it seems that the machine never resumes from S3

the fans stop, the power light goes into blinking mode as you’d expect

pressing any key fails to wake the machine

pressing the power button causes the machine to turn off, pressing again and it starts the BIOS

Turned off extra modules (WWAN etc) in BIOS, set power management to S3 Linux, passed an iommu flag to the kernel, none of those worked.

I got this working with a specific kernel version, worth trying

1 Like

Hi guys,

I recently got a Lenovo X13 Gen3 (a 21BN00BSGE to be precise) and have similar problems with suspending. I’ve tried a few different kernels (the mentioned 6.0.7 and 6.0.8, 6.1.7 and 6.1.12). After a BIOS update and adding mem_sleep_default=deep to the grub config the X13 wakes up upon keypress (in the beginning I had to do a short press on the power button) but than immediatly (re)boots.

TPM, SecureBoot, HT and the fingerprint reader are disabled. Powermanagement ist set to S3Linux. Everything else works “out-of-the-box”.

Any tips where I can look or what I can try out?

Update: The keypress wakeup seems to work only if the X13 was suspended by closing the lid. Suspendig via “Action Buttons” → “Suspend” needs the power button to be pressed

1 Like