Terminal window asking for login/password after Fedora template update

Dear community

I am having a very strange problem never encountered before. I am using Qubes 4 on my Laptop.
Today I updated the Fedora 30 template to Fedora 32 and changed the templates according to the instructions: https://www.qubes-os.org/doc/templates/fedora/

However, after restarting the VMApp sys-net and sys-usb I get a terminal windows saying:

Fedora 32 (Thirty Two)
Kernel 4.19.152-1.pvops.qubes.x86_64 on an x86_64 (tty1)
localhost login:

It will not let me close the window and mouse is disabled. What login is that supposed to be? I tried the screensaver combination, but that did not work. I have updated Fedora templates over the years many times but never had this problem.

Please help, I can not continue to use the laptop.

Cheers
LF

Hello.

can you check if you have qubes-core-agent-passwordless-root installed?

Type

sudo dnf search passwordless

in fedora template terminal and check it is installed. If not, instal it.

Hope it helps.

Please forgive my ignorance. Where do I type this? In dom0 or in the Fedora template?

^ here

No worries in asking these questions! We’ve all went through it :slight_smile:

If you can’t bypass this login, try opening the qube-manager on the fedora-32 template, right-clicking > “Run command in qube”. And then type sudo dnf install -y qubes-core-agent-passwordless-root and hit Enter.

Thank you. It worked on my desktop but not on my laptop. On the laptop nothing happens. Do you have additional advice? Thank you.

1 Like

Reinstalling the template is the other alternative that comes to mind

1 Like