Template update/upgrade pain

OK, so I did umann was kind enough to build templates for people to use. I have been able to update/upgrade the ones I have no problems but the Archlinux one is giving me problems.
So to being…
-upon trying to update/upgrade Arxhlinux template… sudo pacam -Syu
it was producing a “pulseaudio” issue about breaking qubes version… OK I edited… pacman. conf so it wouldn’t upgrade. Ran sudo pacman -Syu again now another issue… libpulse, same thing about breaking qubes, ok edited… pacman. conf again… now these two are not being upgraded. Ran sudo pacman -Syu and it took, about 560mb to download and install…
keyring check was good… no issues
package integrity checked out good. no issues
everything was good to go. Install started and finished with no errors or issues.
Now upon rebooting Archlinux template it went fine in qubes manager. Tou know the “yellow” ball ans then turns “green”. I was thinking all systems go… Well no, no app runs or launches…
I even tried with out starting qubes template and just clicking the app I have displayed under the Archlinix template. Again the Archlinux template will start but no app runs/launches.

Now I have read about increasing disk size, which I did from default to about 7GB and still no app working

I have increased memory from default to 1GB still no app working.

I have change the kernel to what shows in the qubes settings, nothing.

Again Archlinux qube can be started in qubes manager and runs. I can have the template shut down and click a app under the template and it will start the qubes but no app runs/launches…

Any ideas anyone???

can you share logs ? maybe it will help.

Hi @B_ryr,

for Pulseaudio and ArchLinux see:

First: is your ArchLinux TemplateVM work? (Launchable, get a terminal).


and :

  • analyze the ArchLinux AppVM logs,
  • compare with other AppVM
  • try getting a terminal on your ArchLinux AppVM with qvm-run
1 Like

before the update /upgrade everything worked. After the update/upgrade nothing runs/launches.
No terminal or anything…

I will look at the pulseaudio link you guys provided after work.

Funny thing is no errors from anything. The Archlinux template launches but no apps run/launch after clicking them

Thank you for the information. But I am still learning Qubes-OS and adding things to “headers” or having my own “own app repo” exceeds my present skill level and building my own app repo. So unfortunately I will delete this Atchlinux template and either install the old one and deal with it the way it is or just not use it.
Thank you all for your time and effort.

problem fixed boys & girls…
deleted that template, reinstalled archlinux template. Then ran these commands…

sudo pacman --sync --refresh
sudo pacman --sync --needed archlinux-keyring
sudo pacman --sync --sysupgrade
sudo reboot

All is well now!!

Boy has this been a journey learning qubes-os. But I will say a very rewarding one at that…