Template Update Errors (new thread for Fedora)

Getting an error message when trying to update Fedora templates:

Error: Failed to download metadata for repo ‘fedora’: Cannot prepare internal mirrorlist: Curl error (56): Failure when receiving data from the peer for https://mirrors.fedoraproject.org/metalink?-repo=fedora-36&arch=x86_64 [Recv failure: Connection reset by peer]

I was experimenting with Fedora recently and saw that one a lot. And one perfectly ordinary package would simply fail to install after it checked (and listed) all of the mirrors and failed to find it. (Other packages work fine.)

I was using a cacher (sys-cacher). If I shut it off that one package would install, but I’d still get the complaint you describe.

Anyhow, I’m just grasping at straws here, but if you are using a cacher, try disabling it.

how to disable the cacher-template?

That depends greatly on which one you’re using! The one I use has a policy entry in dom0 AND also has some edits in certain config files in the template that is trying to do the update (not the cacher, but instead the one(s) you’re having trouble updationg).

First things first, you are using one, for certain?

I have a template-cacher template yes, that’s correct. Are you referring to the config files located here:


I also get a flood of error messages “qubes.UpdatesProxy denied” whenever I try to update other templates

edit /etc/qubes-rpc/policy/qubes.UpdatesProxy

Find the line starting with $type:TemplateVM and change the target=

change it to what? sys-net? I’ve tried that and it returns the same error

In =>4.1 you should delete qubes.UpdatesProxy and use /etc/qubes/policy/30-user.policy created and based on 90-default.policy

After each change you should run

systemctl restart qubesd

Never. To sys-firewall.

While the new format might be preferred, the old format has not been deprecated yet, and will not be until at least Qubes 5.0.

Source: Qubes Architecture Next Steps: The New Qrexec Policy System | Qubes OS

The old policy format will still be supported until at least Qubes 5.0.

In fact, default Qubes salt formulas still use the old format.

1 Like

Yes, thanks. That’s why I wrote “He should” instead of “He has to”.
Beside other reasons to already switch to new file and format, this should be kept on mind, from the link you posted above:

Due to a potential issue described in Qubes Security Bulletin #38, we have been getting rid of $
However, we highly recommend using only @.

I made the change as suggested…so far so good, one update completed successfully…

Kindly select which reply helped you solve your issue and mark it as answer, so this can be closed.

ok sure.

No, that can’t be the solution. This one could be.

No that was the solution. Why can’t it be the solution?

Ok, how exactly that post helped you to resolve your issue? @BEBF738VD just explained in it that you can still use qubes.UpdatesProxy, but how to use it he explained in his post I quoted? Now I’m confused how you resolved your issue actually.

I followed the instructions as given, updated, and then everything updated successfully.

1 Like

Good for you.