Template Fedora36

I can’t add the French language ?
On the previous version we used system-config-language but with the 36 it doesn’t work.
And I can’t add the free and non-free repositories either.

[user@fed36-bureau ~]$ sudo dnf install   https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
Last metadata expiration check: 3:25:15 ago on Thu Sep 15 06:17:06 2022.
rpmfusion-free-release-36.noarch.rpm            2.1 kB/s |  11 kB     00:05    
Package rpmfusion-free-release-36-1.noarch is already installed.
Dependencies resolved.
Nothing to do.

[user@fed36-bureau ~]$ sudo dnf install   https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
Last metadata expiration check: 3:25:52 ago on Thu Sep 15 06:17:06 2022.
rpmfusion-nonfree-release-36.noarch.rpm         3.9 kB/s |  11 kB     00:02    
Package rpmfusion-nonfree-release-36-1.noarch is already installed.
Dependencies resolved.
Nothing to do.

[user@fed36-bureau ~]$ dnf repolist
repo id                        repo name
fedora                         Fedora 36 - x86_64
fedora-cisco-openh264          Fedora 36 openh264 (From Cisco) - x86_64
qubes-vm-r4.1-current          Qubes OS Repository for VM (updates)
updates                        Fedora 36 - x86_64 - Updates

[user@fed36-bureau ~]$ sudo dnf install vlc
Last metadata expiration check: 3:32:19 ago on Thu Sep 15 06:17:06 2022.
No match for argument: vlc
Error: Unable to find a match: vlc

This is not Qubes related at all. Please check manual first before posting something:

Repolist command-specific options:
  --all                 show all repos
  --enabled             show enabled repos (default)
  --disabled            show disabled repos

If you would have checked that, you would have understood from your layout that “Package rpmfusion-nonfree-release-36-1.noarch is already installed” means repos are installed but just not enabled…

Arff shit, they are relou at fedora, why disable by default a repository that we add!

But thanks for the info, I’ll try to find out how to activate the repository I installed.

For noobs like me, the command in question is

sudo dnf config-manager --set-enabled rpmfusion-nonfree
sudo dnf config-manager --set-enabled rpmfusion-free
1 Like