T430 cannot boot 4.1 installer (tried every fix)

Hello Qubes-ppl,

I really love Qubes and used Qubes 4.0 as my daily driver for a long time. 4.0 works absolutely perfect on my T430 with Heads & coreboot.

Now I’d like to migrate to Qubes 4.1. But that seems to be an impossible task, since I cannot even boot the 4.1 installer.

A few seconds after boot, the sceen flashes a few times. After a long timeout it just throws me into the dracut emergency shell.

At frist, the log shows some strange vblank timeouts. After that, the log gets hammered with errors:

What I tried so far:

  • Tried 3 different USB Drives. 1 brand new. Used dd to write the verified ISO.
  • Tried to dd the weekly build with latest kernel from Index of /qubes/iso/.
  • Tried to repack the ISO with modified isolinux.cfg. Since the errors seem to be connected to i915 driver, I added kernel parameter video=SVIDEO-1:d, i915.enable_psr=0, i915.force_probe=*.
  • Tried other OS-Installers. All boot without problems. Even Fedora 35, which seems to be very close to Qubes 4.1 installer.

Any ideas, what else I could try?

Is that NitroPad? You may need coreboot update, see Firmware Update v1.4+ — Nitrokey Documentation

I’m already running Heads 1.4.2. It’s even mentioned in the vblank crash log:

Ventoy boot? I did not try it myself but it is very popular with i2p users. You can get it at tracker2.postman.i2p maybe some other places. The description is english if you follow the link.

The actual version would be Heads 0.2.0-1150. I have two T430 running R4.1 perfectly:

There are also two more HCL reports running R4.1 on T430 using either the Lenovo BIOS or coreboot/SeaBIOS. So don’t give up! The evidence is overwhelming that it works on your machine. All of the reporters had no issue in installing it.

First step: is this a NitroPad? … if so, maybe contact them for support?

Yes, it is basically a Nitropad with slightly different Hardware (extra RAM + Intel 3740qm).

The latest release from Nitrokey Heads is installed (GitHub - Nitrokey/heads: A minimal Linux that runs as a coreboot or LinuxBoot ROM payload to provide a secure, flexible boot environment for laptops and servers.). But I don’t know which Heads build it is based on.

The hardware ID of my T430 (2349Y3D) is different from yours. So maybe some components are just not compatible with Qubes 4.1.

Sad. It worked so good with Qubes 4.0.

If you have an eprom programmer you could backup your current firmware and reflash the stock firmware, just to see if the firmware is the issue.

I do not think that is the case. If I understand you correctly you build the T430 yourself / did not buy from Nitrokey and then just flashed their firmware – correct?

Do you have a hardware programmer and feel comfortable doing this? I am happy to send you my ROM file for a quick check. If it works, you might want to compile/build one yourself.

Alternatively you could install R4.0.4 and run an in-place upgrade to R4.1

Have you found a fix yet?

Got the same Problem with a modified T430 from Nitrokey (more RAM+other SSD).
Only that is is a new install on an empty SSD.