System firewall fail

Just installed 4.1.2 twice, I get this error both times. No idea how to fix this.

Are you willing to also share what’s in /var/log/libvirt/libxl/libxl-driver.log in dom0? :wink:

bugger - that didn’t help much … :-/

What do you get, if you open Qube Manager (Q → Qubes Tools → Qube Manager), highlight sys-firewall, click “Settings” (at the top) and open the tab called “Devices”?

What device are attached to sys-firewall? (Check in qube settings → Devices)
If device 0000:00:1f.6 is indeed listed in “Selected”, click on the button “Configure strict reset for PCI devices”, select the device in there and click “Ok”.

1 Like

Install number 3 when i boot up I get this message.

Click on “Ok” and keep going with the install. Once you are on Qubes, check what was said earlier here so we can understand where the issue is coming from.

Is this sys-firewall?

It seems that 00:1f.6 is your ethernet controller, in that case you’ll need to open sys-net settings and do what I said earlier:

1 Like

sys-firewall Devices - Yes

Yes thank you that seems to have fixed it. I am now able to update system.

1 Like



Got exact same problem but it’s not solved for me.
When I go to sys-firewall devices I have this message : “You’ve enabled dynamic memory balancing. Some devices might not work!”
And then, when I select network device and try to validate it I have : "Can’t attach PCI device to VM in phv mode¨
Same network controller Intel 219.
The network controller is selected correctly in sys-net and I removed there the wifi controller.

First time I install Qubes and I must say it’s rather harsh !

sys-firewall shouldn’t have any devices attached. If you are looking for your network controller, it should be used by sys-net instead. Check the settings and then try to reset the PCI device from there.

Ok, solved here too.