Sys-usb not configured correctly?

Hello, there are several problems with Qubes USB, yes, I have a USB keyboard and mouse, so during the installation, the sys-usb was not created,
I tested the possible configurations from the documentation and I do not understand whether this sys-usb was created or not, i explain and so a few questions.

Before config :

If I create sys-usb it will be listed in qube manager as service: like sys-net etc or not?
After the installation, when I didn’t change anything in the dom0 terminal, I connected the usb via qui-devices (is it good? I guess so, was it already as sys usb?)
One time it didn’t work before and accidentally instead of connecting it via qui-devices there was an icon signed Most recent Devices and I clicked open with file manager Click to access this device from other applications
does it mean that i opened untrusted usb (from old PC) to dom0 ? reinstall for security is the system potentialy “broken”?

Configuration:
After the above, I decided that I would do as it is in the documentation, so I started with: sudo qubesctl state.sls qvm.usb-keyboard
which was wrong because I have more usb ports (9) so it blocked keyboard when decrypting disc , however, as someone advised, I unlocked it in grub
then I corrected it from the section below that is:

Qubes 4.1: How to enable a USB keyboard on a separate USB controller
I think I found the correct assigned controllers with the help (Right USB Controller), but there was a problem at the start with: Open the file /etc/default/grub in dom0 and have information :Permission denied.
Searching the internet, someone wrote to use not sudo but sudoedit and with sudoedit I could edit: GRUB_CMDLINE_LINUX and add the correct controller according to me, but
I don’t know if I saved these settings correctly because I exported the .cfg file to domO there was no other saving option, what next?
After reboot, the keyboard and mouse work on all ports but usb disc do not work in any ports … connect the usb disc does not display it at all.
will someone explain?

If you open ‘Qube Manager’ you can see all the Qubes you have.

What exactly is not working? A usb stick?
Do you see any error messages?

Can you also please list the output of
qvm-pci list

So we can check if you have all the correct USB controllers assigned.

I don’t think that actually answers the question (qubes-usr is talking about the manager); qubes.usr seems to be asking whether it will be one of those qubes with the hole in the side of the icon or not.

There is a setting to show it’s a service vm (I think it’s a “feature” settable through qvm-features) but I’ve found that setting that, though it makes it show up as, specifically, a service qube in the manager, that setting doesn’t “stick” when you reboot; you have to set it again. Only if it also provides a network (and sys-usb doesn’t) will it remain set when you reboot.

Devices such as ext hard drives etc. don’t work. There are no errors, nothing is displayed in qui devices or even in most recent devices. It stopped working when I changed it GRUB_CMDLINE_LINUX when Add " usbcore.authorized_default=0andrd.qubes.dom0_usb= " in sudoedit so I will delete this command that I added and let you know, but still as to my question about connecting usb (when earlier worked, before config separate usb) not via qui devices but via most recent devices or was it connected to dom0 ?

So the only option with multiple usb ports to have sys-usb is this right ? :

Qubes 4.1: How to enable a USB keyboard on a separate USB controller

so maybe someone will refer to the fact that already at : “2.Open the file /etc/default/grub in dom0” : I have a permission denied message, there is nothing described for such a message in the instructions. does sudoedit bypassing this change anything?

Hi bro.

Me too having problems with sys-usb. You must enable root mode to use the command. Use sudo -s location. Use the nano command to edit the texts. I’m a beginner too, but I hope it’s useful for you.

@qubes.usr

There is some communication barrier here, I am not quite sure what you are asking in regards to your other issues. Can you please do the above and show us the output of the command here.

I changed the question and now it’s like this
how to regain access to usb via qui-device (without sys-usb)
I plug in a USB device and it’s not in the qui-device list