Sys-usb doesn't see any device upon restarting the qube

I’ll probably change the topic title once when things get clearer.
I have xHCI controller handled by separate sys-usb based on fedora-36-minimal.
I have storage and other usb devices attached to it.
Recently it just stopped to mount/populate devices after restarting sys-usb.

I tried:

  • autostart sys-usb on boot. Mounts/populates all the devices.
  • manually start sys-usb after boot. Mounts/populates all the devices.

In both cases when I restart sys-usb devices become unavailable, not seen by lsusb. The only thing that helps is to restart Qubes.

No traces in journalctl -f while restarting sys-usb.

Any hint how to start to trace the issue is appreciated.


But would it work on a non-minimal sys-usb?

Thanks, I’ll try that (have to create dvm-template for it). But, it worked on minimal. until I reorganized devices attached to controller (moved some and attached the other ones). Nothing I did in it’s templates.

Sorry to poke you @marmarek, but I think you’re probably the only one who could have an idea how to overcome this issue. Thank you in advance.


For troubleshooting purposes, a reasonable step to take would be to rename your current sys-usb based on fedora-36-minimal and recreate a new one with debian-11-minimal.

Please post results after you’ve done this.

Thanks for the reply. Eventually I decided to base my setup on fedora minimals, so far even transiotioning successfully to a testing fedora-37-minimal (except cacher, of course), so that is why I didn’t try with debian minimal. I’ll try to reproduce the issue and be back with the outcome.

Doesn’t sound very successful if " Sys-usb doesn’t see any device upon restarting the qube" …

Again, rebuilding would go along way to troubleshooting what you’ve done wrong/messed up.

For some reason, my controller’s sys-usb won’t restart and mount devices anymore without permissive flag, so I now need to use both options, with no-strict-reset=true as the other…

It is mystery though that it works on the first start upon boot (manual or auto), as described in the OP?!