Sys-gui-gpu blackscreen

Hello, I’ve been working on sys-gui-gpu for a while now, however, I’m not sure if I’m doing it wrong. During my setup, I faced a black screen issue every time I try to boot up sys-gui-gpu. My solution was to block i915 using kernel parameter module_blacklist=i915. Is there any other way to make sys-gui-gpu work without blocking the graphics driver? or is this a necessary undocumented step?