Sys-audio and Win(7) qube(s)

While successfully set it up to work in Linux based qubes, I can’t seem to make it work in my Win7 standalone and template((s) based qube(s), nor in a template itself) .

This is probably question for @jevank, but if anyone has any experience or suggestion, it would be more then welcomed.

Sound works when audio device is in dom0, so no usual tip like …audio-model ich6 is an issue - it’s already implemented.

$ qvm-tag win7

I don’t have a chance to test sys-audio yet, although it might be interesting to connect bluetooth devices. Try first to check if sys-audio starts the pacat-simple-vchan process for the windows VM.

Thanks for your respomse as usual, @jevank
I must admit that after I found a way to passthrough audio device to sys-audio, it practically started to work out of a box for Linux qubes.

So as I just started to learn about audio virtualization, I couldn’t confirm that I understand everything is written on

When I run

[user@dom0 ~]$ sudo xl list

beside others, I’m getting

win7 23 3072 2 -b---- 653.7
win7-dm 24 144 1 -b---- 5823.0

So back to sys-audio, when I execute

sudo pacat-simple-vchan 23 win7

cursor just goes to next empty line and sits there blinking?

I have no idea what win7-dm is from above, though, but I tried the command against it, too, and I got response

Another instance of pacat-simple-vchan is already running for this VM (PID: 2368)

What should be the output of the command when working correctly?
When to run this command: win7 is off, running without music playing, running AND music playing?I

I see sound bars in win7’s mixer both in master and player bar, so it sends sound obviously.

If you don’t have time, some links to learn from would be good too!

Thanks in advance and keep up great doing!

I’d say it looks the same as when, for example, alsa-plugins-pulseaudio is missing for fedora, but for windows… :grimacing:

Solved, for others bumping on this topic.