Suggestions for booting?

I installed Qubes on an USB drive and it works with one laptop. Now I’m trying to get it to boot on another laptop. It is a model which is on the HCL and should work.

In the BIOS, it recognizes the USB drive brand and size. That USB was placed at the top of the boot list, but it always boots to Windows instead. I have Secure Boot and some other options disabled.

Can I get suggestions for how to get it booting?

what is the laptop manufacturer?


press f12 until boot menu show up, the use arrow key to select usb <something> then enter

of course you might already known this (as it a essential skill for advanced user), but since your method to boot usb is not always work, try it

Yep I already put the USB (brand) (size) at the top of the boot list.

I have now tried to boot to a different USB which works on my other laptop, and it’s also not working. But I get the Lenovo logo popping up twice and when I have the different USB plugged in, it won’t let me enter Startup.

does it match anything in here and here?

1 Like

TechExplorer - I am not sure you have understood what ppc has said. i.e. Instead of allowing the normal boot process to proceed interrupt it by pressing F12 and you should be able to select you boot device (i.e. Harddisk/ Mass Storage Device) from a list.
This is a BIOS feature independent of the boot order set in BIOS.

1 Like

Thanks. Yes, I was confused when I responded. After that, I realized. But the F12 Boot Menu does not give me any USB options. I guess that may be a clue.

I believe this (F12 key) option can be disabled in BIOS and it may be another key on some computers.
On some laptops you may only be able to boot using specific USB ports also. If you have a USB port at the back of your laptop it is probably worth trying that one.

The F12 key works but in the menu, USB is not an option. Even though it is an option in the Boot menu (in Startup options).

I have also tried each USB port of the laptop :neutral_face:


you can’t

Hi ppc,
I don’t like to be argumentative but you can disable the (F12) boot device selection option . :wink:
Lenovo - ThinkPad P50 BIOS - Startup (menu) - Boot device List F12 Option:[Enabled/Disabled]
I don’t know about other Lenovo models though but I think they are quite similar.
Fortunately it appears this is not the issue for TechExplorer.

I know of a Lenovo laptop that will only boot from USB ports that plug in from the back beside the power port and booting from those ports can be disable from BIOS. There are also UEFI / Legacy mode options that you may need to be aware of. (BIOS Startup menu). I expect the default BIOS settings should work but then you will normally also need to enable virtualization hardware support, so I think you should have a look at the links that ppc posted if you haven’t already.

Is there anything else I should try before I try to make a new UEFI installation stick?

I tried “Legacy Only” in the BIOS settings but then it gives me this error with both of my bootable USBs (that work on my other laptop):

PXE-E61: Media test failure, check cable
PXE-M0F: Exiting Intel Boot Agent

Yes, I have virtualization enabled and those USB ports are enabled. I began to see both of my USB devices in the F12 Boot Menu, but when I selected them, the screen would just go black for 1/2 second and then show me the Boot Menu again. But it could clearly recognize when I had one plugged in, the other, or neither.

I think it is time for me to sleep … so I think this will be my last comment for the night.
There appears to be some issues related to booting and virtualization raised in one of the links that ppc refereed to that might be worth looking at. On one Lenovo I found that booting from USB was not working well for me and I ended up using an external USB DVD drive and DVD to boot.
I hope you find a solution soon.
I would hope the Both (Legacy and UEFI) option would work. I am not sure which boot mode is required by the USB stick. I don’t think there is any harm in trying UEFI on its own as well.

1 Like

I will look again at the links. From my first look, I think that the only thing applicable was making new installation media.

I tried Both which didn’t work. Maybe I should try UEFI Only.

Check in your bios are usb detected ? if yes, then maybe your uefi firmware didn’t recognize efi boot, get you qubes os media installation, boot into rescue mode, skip to shell, check your disk, assumption that your usb is /dev/sdb.

efibootmgr -v -c -u -L “TechOxpo” -l /EFI/qubes/bootx64.efi -d /dev/sdb -p 1

1 Like

you giving me some frustrating

that the network boot