Sudden asking sudo password? (after removing cheese and keepassxc)

just removed some unnessesary progs on a stand-alone-vm and after some sudo dnf remove comes: “We trust you have received the usual lecture from the local SystemAdministrator. It usually boils down to these three things: … and so on”

Whats that?? Because i made no password for sudo.


You might have removed the passwordless root package.

Check if you have qubes-core-agent-passwordless-root installed.

But since you may not be able to become a super user on that machine, you’ll probably have to do it via dom0:

qrexec-client -d <TARGET_VM> root:bash

Where <TARGET_VM> is the affected VM.

After running the command you’ll get a shell inside the VM running from the root account.

1 Like

it doesn’t start the shell

try writing the command pwd or gnome-terminal. That is a very weird shell without the usual feedback you’d expect.

but i must do it via dom0, how can i make it?

you run that qrexec-client... command in the dom0 terminal and then the others inside the “shell”

but there comes no shell after that command in dom0
nothing comes

I think qvm-run -u root <TARGET_VM> xterm is easier for most users if it works. Try this one @qun.

1 Like

ok, thanks… it starts the xterm in the vm

WOW… i can now install qubes-core-agent-passwordless-root … but i did not removed it. I removed xpassxc and cheese

really really strange! I have no network within.
ping shows me “network is unreachable”

somebody any idea?
i think, i somehow killed some settings with removing cheese and keepassxc… no idea how.
I can not even move the stuff to a new made vm… puh…

Templates have no network access - they use a proxy mechanism explained

this in not a template, it’s standalone vm

Yes, I missed that, sorry.
I’m assuming you had network access before this rabbit hole? How did you
create the StandaloneVM?

Check the network settings ( qvm-ls -n <qube> in dom0), and make sure they
match what you have in the StandaloneVM, and also check /etc/resolv.conf.

thanks, this is a real rabbit hole… have no idea, how does it suddenly happend!
i created it just over the qube manager.

It shows me, that the vm has sys-firewall as netvm, IP x.x.x.x IPBACK is empty and then Gateway x.x.x.x
The IP of the sys-firewall is wrong (!!!)
how could it be??

In the resolv.conf of the vm i have two nameservers
don’t know what it means in that context.

vm and gateway (fw) IPs seem to be write 10.137.x.x

not even qubes-usb-proxy is installed in the VM… WTF???

it seem to be completely isolated… so i have no idea, how can i get my data copied from there to another vm and just kill this rabbit hole after that.

Guys… come on, i’m stucking here in a real stupid way :slight_smile:
that’s overwhealming my know how.

How can i at least just copy the data to another app-vm from this somehow killed one?

I guess you can just create another standaloneVM and copy the data over. You don’t need root for that.

That’s what I wanted to do, but i can not move any files to the created vm.
If i rightklick on the file, there is no option to copy it to another vm anymore.
I can not even mount usb to the ruined vm.
So what is the possibility in that case to get the data I see (and r/w)?

I don’t know how I didn’t remeber to point this out to you first… And it’s probably too late now, but if you break a VM you can always restore it to the last state it was in:

If it were an AppVM (I guess the encouraged option), it would be as simple as switching the template. But since it’s a standalone, it’s a bit more complicated.

I guess something you can do is to a backup of that qube and then perform an emergency restore of that (potentially at a later date). But this is a complex process.

wow… ok… i will read about it theese days, thanks!
So there is no way just to copy the files to another vm?

And this way " Qubes Volume Backup and Revert" ist just for app-vm?