Stuck upgrade in STAGE3 - Is now possible export/import VMs before reinstall from scratch?

Hi all.
I’ve tried (without success) in-place upgrade from 4.0.4 to 4.1
After the break of “–all” option at STAGE1, I’ve followed manual upgrade between stages, but at the end of STAGE3 , script INFO suggests (wrongly!) a system reboot.

Now I’m unable to revert or complete upgrade, so I’m thinking to do a fresh install.

Before I’d like to export VMs to an encrypted external hdd (of course backup/restore is not a working option now, because usb-vm doesn’t boot, and previous one I have, I’m unsure is the latest release).

Can You please suggest me how to do it?
Thanks a lot.

I’m thinking about boot from usb, luksOpen /dev/sdaX, and then?
Thanks anyway.

You can simply perform a clean reinstallation and restore from the backup you created on 4.0 before starting the in-place upgrade process. It doesn’t matter if you created the backup on an earlier Qubes release. They can all be restored on subsequent releases. The Qubes backup restore tool is backward-compatible going all the way back to version 1.0.

Hi and thanks for your answer.
Yes, that’s what I’m going to do if there’s no other way…
From what You say, it seems that my hope about saving latest version of “personal drive” in my VMs isn’t a working one.
What a pity…
Thanks anyway,

I’ve tried, but not everything is as expected…
Restored VMs, but it’s impossible restore dom0 backup, because the backup is larger then actual dom0 and seems it doesn’t auto-grown during restore.
Have You any other suggestions?
Thanks a lot.

If you’re using the Qubes backup and restore tool, then that shouldn’t be a problem. Your dom0 backup just gets restored in a subdirectory of the new dom0 home directory. The dom0 backup is usually pretty small for most users (or even empty), since not much is done in dom0. It’s not as if you have to copy the entire backup into dom0 (nor should you). Recommend following this guide:

yes, normally it’s so.
But in my case, I’ve created a storage.img drive, of about 35GB, that I occasionally use to share data between 2 VMs, by loopback from dom0.
Now, dom0/home is less than 20GB, so at the moment it’s impossible restore 35GB in 20GB; I’ve realized it when - during restore - I’ve seen an alert about finishing space in /var of dom0; so I realized what’s the matter.
So what do You suggest?
To grow dom0/home to fulfill restore requirement (do You have a link on how to do it) ?
thinking about something like:
~ sudo lvresize --size 40G /dev/qubes_dom0/root
~ sudo resize2fs /dev/mapper/qubes_dom0-root
Or it’s possible to extract only Documents/scripts from dom0 backup, as they’re really needed and discard previous full backup?
And in this last case, how to do it?
Thanks a lot.

Sorry, I have no experience with how to deal with that situation, as I have never attempted such a thing myself.

Perhaps something in our advanced documentation might be able to help.

For that, we do indeed have detailed documentation:

Thanks for all your suggestions.
Indeed, advanced documentation isn’t updated for v.4.1 and backup one doesn’t explicitly examine the dom0 case, so… it’s a try!
thanks anyway.