Split-browser (TB Security Level: Safest) not working

Even prior to today’s split-browser-disp upgrade, it was today that I first noticed that starting Tor Browser in this mode doesn’t work. Browser is started in Standard mode and with the notification bar about setting display language based on my system’s language.

Few days ago Tor Browser was updated to Tor Browser 12.0, but I had opened instance until today of previous version running, and I don’t know if it’s related to issue. It happened when I started new dispVM via split-browser with v12.0 for the first time.

Am I the only one facing this?

Indeed Tor Browser 12 broke it and it’s fixed since qubes-split-browser-0.15.4. Until that version makes it into qubes-repo-contrib (which is currently stuck at 0.15.0), you may want to manually apply this change on the persistent side, and maybe also this other change to hide Tor Browser’s new display language notification on every startup.

Wait, what?

Now, this is complete mystery to me

[user@fedora-36-mininal ~]$ sudo dnf list qubes-split*
Last metadata expiration check: 0:44:51 ago on Sun Dec 11 11:25:07 2022.
**Installed Packages**
qubes-split-browser.noarch        0.15.0-1.fc36   @qubes-contrib-vm-r4.1-current
Available Packages
qubes-split-browser.src           0.15.0-1.fc36   qubes-contrib-vm-r4.1-current 
qubes-split-browser-disp.noarch   0.15.0-1.fc36   qubes-contrib-vm-r4.1-current 
qubes-split-git.src               1.0.1-2.fc36    qubes-contrib-vm-r4.1-current 
qubes-split-git.x86_64            1.0.1-2.fc36    qubes-contrib-vm-r4.1-current 
[user@fedora-36-minimal ~]$ sudo dnf upgrade qubes-split-browser
Last metadata expiration check: 0:45:38 ago on Sun Dec 11 11:25:07 2022.
Dependencies resolved.
Nothing to do.
[user@fedora-36-minimal ~]$ sudo dnf upgrade qubes-split-browser --refresh
Qubes OS Contrib Repository for VM (updates)    1.2 kB/s | 3.7 kB     00:03    
Qubes OS Repository for VM (updates)            201  B/s | 833  B     00:04    
Dependencies resolved.
Nothing to do.

What the heck?

Ah, I was updating my reply:

1 Like

Ah, got it now, thanks. Let me patch it and will be back.

Hey rusty, here are my findings:

  • removing language notifications works. Thanks.
  • change for the safest security level works. But, unlike with previous versions, now security level cannot be manually changed in Tor Browser’s settings to lower level (safer) which I actually need in order to log in here on the forum.

On the contrary, when Tor Browser is started in Standard security level, it is possible to change the level to any other.

Weird things, I know, but I thought you might wanted to know…

1 Like

Yep, unfortunately that seems to be unavoidable at the moment as a result of having to use lockPref(), see commit message. I haven’t really looked into it that much.

1 Like

Well, I can start it as Standard and increase it manually to Safer. Same amount of work. So, for me this is resolved. Thank you once again.

1 Like