Some questions - I really need help!

Hi, I’m pretty new to Qubes and could really use some advice. I’m on 4.0 and I just upgraded my Whonix from 15 to 16.

  1. On Whonix 15 I used an RDP app inside WS-15 to connect to a VPS via RDP. Since upgrading to Whonix 16 and putting RDP app inside WS-16 it doesn’t want to connect. It brings me to the log in page and after I type in credentials it just says it can’t connect. I tested WS-15 / GW-16 and it worked like normal so issue must be with WS 16? I tried a couple different RDP apps and same issue.

  2. Is above connection secure?

  3. If I can’t find solution to above issue, would it be okay to use RDP app inside WS-15 / GW-16 or is that unsafe?

  4. After Upgrading Whonix I was having an issue where salt wouldn’t update. So I opened Qube Manager and updated about 5 Qubes from there. Was that a mistake on my part? Could that have bypassed Qubes security and allowed malware in?

  5. In general I’m finding my Whonix connection very slow even though I have 300 mbps internet. Is there any chance I could have configured something wrong to cause it to be so slow? For example just downloading Fedora 34 took hours. When I upgraded my Whonix all I did was follow the instructions on the Whonix site. I updated dom0 with sudo qubes-dom0-update command. I saw about 10 packages were updated/upgraded. I then typed the command sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw-16 qubes-template-whonix-ws-16.

After it was all installed I changed all my Qubes to WS-16 and sys-whonix to GW-16 template.

Any mistakes above?

have you asked on whonix forum?

it ok

no, it very rare case that only government (and most thing related) can do

might tor cause the issue and there almost nothing you can do about it if tor cause

strange. If ws15 - gw15 was working, I wonder, why ws16 - gw16 didn’t anymore. Sounds like somethings (package) is missing on the new whonix-gw/ws-16 VMs.
Maybe a Whonix issue and so nobody here can help…

For all other questions: No mistakes, looks good from my end. As long as we use the Qubes updater and the terminal commands (issued by the Qubes Administration and listed in the Qubes documentation), all is fine and just what was mentioned by ppc… “only government (and most thing related) can do” such technical break-in’s into your enviroment.

I did ask on Whonix forum but no response yet… I wonder if it’s worth deleting the whonix 16 templates and downloading again…

You think it’s safe to use WS15/GW16 to connect to my VPS for now? Am I right in thinking that if tor is broken they would still need an exploit to break out of the VM to discover real IP?

Your IP is save as long as you use the Whonix system, regardless if you using ws16/gw16 or ws15/gw16 or ws15/gw15…

In the end I would think if you really need to download “a whonix-xx-16” template again, then it should be the ws-16 version I think, because the ws15-gw16 connection seems to work…
…but I don’t think it’s an issue with the ws-16 template. My question now would be: is any other service working on the ws16 - gw16 connection? What’s with running tor-browser on anon-whonix (from a ws-16 template) ? Can you access your .onion sites?
Then it looks like an issue with your RDP app

Yup every other app works normally in the WS16/GW16 setup. Everything but my RDP app. I even tried 2 different ones and same thing.

I wish I knew a way to not use RDP… I just want to go through tor but a couple websites I want to use ban tor so I need to use residential proxy…