Screensaver Doesn't Turn On as Expected and Blocked By StandAloneVM

My screensaver is set to turn on after 10 minutes. I am running a StandAlone VM in HVM mode running a graphical Ubuntu-based Linux image.

I am using this VM because I am running an App that does not run in XFCE4 in Qubes without errors because it needs to display in the panel and is incompatible with it. I have tried fedora, fedora-xfce, debian, and whonix-workstation templates and get the same errors so I have used the standalone VM. The App is able to run in this VM, which is connected to sys-whonix and gets Internet.

This VM also has a screensaver and it’s own password which is different from the Qubes screensaver password.

When this VM runs, Qubes sometimes does not automatically run the screensaver especially when The VM is already at it’s screensaver.

I have also seen the VM screensaver look like it’s being activated and then say something like “deny” or “blocked” and go back to it’s screensaver. I think this is happening when Dom0 is trying to turn on the screensaver of dom0 and somehow the VM is blocking that.

It’s also possibility the VM is being hacked through sys-whonix and that’s why the password box in the VM shows that there was an attempt at some sort of input. I am running a firewall inside the VM. I have not run software that wasn’t verified with gtkhash. This error has occurred with more than 1 tor node.

What should I do next?

This problem suggests an isolation problem. If the Standalone VM is isolated how can it block dom0 screensaver?