Ryzen 7000 serie

@Rnd3sB3g13rng how did you go with narrowing down the problem? I notice there does not appear to be an issue raised yet.

I will add another data point here: same problem with 7950X + Gigabyte X670E MB: normal installation of 4.2.0rc1 runs through to just after saying “Configuring networking”, on the second pass, then a hardware reset. Further boot attempts always hardware reset just after entering disk pass phrase. Need to add “qubes.skip_autostart” to linux boot options, boot up, untick start at boot in sys_usb, manually config networking and system is running. I found that sys_usb was OK with 4 out of 5 of the A670X USB controllers enabled - they seem to work fine. Don’t need x2apic=false at any time.

The problem is with device 37:00.0 something different about this controller in the 670 chipset?

[ed] MB is X670E

Quick followup: I lost my MBR (not Qubes fault) so had to reload - tried the latest kernel instal, same result that problem is with just one USB controller, leaving it not passed thru to sys-usb allows the system to function normally. Yes it is pretty snappy at runnning Qubes. I have the 3D processor which has slightly lower base clock and 1/2 power consumption, typically, than 7950X.

I now strongly suspect that the problem is with the controller on the CPU that is being used for the mouse and keyboard. Noticed another user with a problem mapping an active USB conotroller: https://forum.level1techs.com/t/passing-usb-controller-with-connected-usb3-device-reboots-host-on-x670e/192335

Hey, sorry for the late response.

Actually it was try and restart a bunch of times.

  • First boot with 4.2.0rc1 bootstick (x2apic=false, tbh I don’t know if it is really required, but it’s working now and I will do a clean reinstallation anyway for 4.2.0 or 4.2.1).
  • Second boot (x2apic=false, just to be sure): I set the option “don’t set up anything” and clicked ok. You are forwarded to the login screen now.
    Then I ran sudo /usr/libexec/initial-setup/initial-setup-graphical in dom0 and installed it qube by qube.

What is you problem in detail? I have not had any networking issues, only one of the usb controllers resulted in instant restart of the whole system when attaching it to sys-usb.

I wrote up my problem, which is the same as yours, in https://github.com/QubesOS/qubes-issues/issues/8322. No networking issues, runs like a charm. Not ready for a daily driver for me yet (pity as it is a delight to use), just using as an app server now.

[ed} You could add a note to that issue regarding the correct way to workaround.

1 Like

I’ve just tried installing both 4.1.1 and 4.2.0-rc1 to a 7940HS device. No dice. The GRUB menu loads up off the the USB just fine but none of the options work.

Once a GRUB option is selected the computer reboots itself twice and back to the GRUB menu. Selecting the “Troubleshooting - verbose boot and install” option leads to 2 seconds of log entries, then the same reboot back to GRUB.

I’ve tried putting in both x2apic=false and x2apic_phys=true in the GRUB boot parameters without success.

EDIT: If anyone without 7940HS/Phoenix APU hardware needs someone who does to help troubleshoot ideas into a working Qubes install, just get in touch. Happy to test and give things a try as compatibility (hopefully) emerges over time.

1 Like

Heartbreaking. I hope that Qubes team will make 7940HS and other CPUs from Ryzen family working before the final release of Qubes 4.2.

Okay I have the same problem with the Ryzen 9 7940HS.
Then I’ll wait until the problem is fixed. Greetings

Greetings. As for me I had better luck with Ryzen 7 7735HS.

7735HS is zen3+
7940HS is zen4

New architecture.

Thanks, I have now ordered another computer with 7735.

Why AMD? Intel is better for Qubes.

Is an i7 better than a ryzen 7? I had seen when comparing that the i7 works with DDR 4 and the ryzen 7 with DDR5, where I see more advantages

It’s not useful to compare CPUs performance only by their manufacturer.

Well, I want a computer that is optimal for Qubes. I thought it would be ryzen with 64gb DDR 5 ram. The DDR5 ram is probably 50% faster than DDR4. With i7 I would have to go to i7 13xxx because the i7 12xxx only takes the DDR4. I think the RAM speed is important, or how do you see it. I appreciate your advice, I can still go from 7735 reorder to i7. Greetings

I will share with you one secret no one knows: AMD architecture is good for energy efficiency. Intel arch is good for single core performance.

Qubes = Software graphical render = Single core IPC = Intel

Intel single core IPC = ~2250 with 13th gen CPUs. Best AMD CPU you can use with Qubes is zen3+ arch, so it is ~1600 IPC. Intel is 30% faster in terms of rendering graphics (smooth browsing and etc). It is crucial.

So buying AMD is very bad idea.

RAM bandwidth is no importance. Single core performance is the one that rules Qubes.

1 Like

My machine has a 7940HS and Qubes (RC3 & RC4) seems to be running fine in the short time I’ve been testing it. Didn’t eve need to add any special parameters in GRUB.
I did need to update the BIOS before it would install.

Wow. Thats good news. Could you please share more details? What is your laptop model and version of bios update at least. (probably there is useful information in release notes of bios update)

I saw your post somewhere, where you wrote that you had successfuly installed QO 4.2 on 7000 ryzen. Could you please share your experience?

To be noted, with recent xen patch available in QubesOS R4.2, there is no need anymore to add “x2apic=false” or “x2apic_phys=true”

1 Like