Restoring Qubes after laptop hardware failure

Hi there, bit of a Qubes noob here. My X1 Carbon Gen5 laptop on which Qubes was installed failed, but the NVMe drive is intact and fine. I was unable to replace it with the exact model but have obtained an X1 Carbon Gen6 instead. I tried just putting the old NVMe drive into the new laptop, but it did not boot even though I’ve set BIOS settings to those which have worked for other users (UEFI only, no CSM, disable thunderbolt controller, suspend set to linux mode, vt-d enabled etc). TBH I am far from a UEFI wizard but I did suspect there might be some other steps I have to do. How do I get my Qubes install to boot up on the new laptop?

I know, I should have a backup (and I do). However:

  1. There is some gap between my most recent backup and the time the laptop failed, as inevitably happens.
  2. My Qubes drive was 1TB in size and the replacement laptop I got has only a 256GB drive so although I don’t know how full my drive was I don’t think I can just restore to the new drive and either way I would like to have the 1TB drive in my new install anyways. So it would definitely be best if I can just do something to get the same drive to boot in the new laptop.

Any help/suggestions are appreciated. Thanks!