Qvm-pci "failed to list pci devices"

I’ve been messing around with QubesOS on my device for a couple hours trying to get GPU passthrough setup. It seems that, atleast from dom0 which is where I assume I’m suppose to set this up, qvm-pci list returns an error “Failed to list ‘pci’ devices, this device type either doesn’t not exist or you do not have access to it.” I’ve been using QubesOS for nearly as long as I’ve been trying to solve this issue so sorry if I’m missing something (like if I shouldn’t be doing this within dom0 as root). I cannot seem to find anything in /sys/kernel/iommu_groups either.
lspci does properly return a list of PCI devices though.

This is a VERY fresh install.

My setup:
-Intel 11th gen mobile CPU w/ integrated graphics
-NVIDIA RTX 3070 (Nouveau driver disabled w/ kernel parameters, nvidia driver not installed)
-HP laptop
(Yes, I’m on a machine other than the one I described in my previous post)

I found a thread about this and the user solved the issue by disabling Intel Volume Management Engine in the bios, the only problem is that I’m on an HP potato machine. If you’re not familiar, the HP bios is so limited you can barely do anything with it (there aren’t even options for XMP and whatnot, just turn off and on secure boot, and some other basic things).
I’ve done IOMMU on other distros on the exact same configuration without issue.

When you run lspci, do you have domain that start with 0000 and a few with 10000 ?
Does your device tab in sys-net is disabled/grayed-out ?
I think you got the same problem as this post.

There is also an open issue on github (link is in the lastest reply of the above link).

With lspci, yes
2 PCI Bridges
Intel Corporation 11th Gen Core Processor PCIe Controller
Intel Corporation Tiger Lake-H PCI Express Root Port
2 “Non-volatile memory controllers”
They’re Sandisk SSDs stuff.
They have the 10000:e*

Yes, in sys-net, devices is grayed out (it’s grayed out on every Qube I’ve checked).

The solution (workaround) is in the topic I posted and also on the github link. :slight_smile:

It worked.
How often will I have to reapply this change? How does Qubes update? Is it like Windows where the updater will break upon a modified system file?

Everytime that qubes-core-admin-client will be updated, I guess you will have to do the change again.
How often, I don’t know, but not so often.
The update will not break, it will just erase your changes.