Qvm-open-in-dvm in application other than firefox

Using qvm-open-in-dvm, I’m trying to view/edit files (and not links) in their respective default application in a disposable VM, however it seems that they always open in firefox regardless of extension. Is there a work-around for this, or is this an unintended glitch that I’m experiencing?

You don’t need a workaround nor is it a glitch. What it reflects instead is how the file types are assigned in your dvm template.

If you are attempting to view a PDF file and it opens in Firefox, that’s because your dvm template is currently configured to open PDF files in Firefox. Same for images etc.

There are multiple ways to change this, but an easy and GUI based way is this:

  1. send a file of this type to your dvm template
  2. run nautilus inside your dvm template
  3. select the file and right click, select properties
  4. go to the “Open with” tab and select your preferred application for this type
  5. click “make default”
  6. delete the file to keep your dvm template clean (don’t forget to empty trash)

… repeat for each file type.


Ok so I did this for a text file and a keepassxc database and the text file would open up the correct application, but only when it wasn’t an empty file weirdly enough. The database file wasn’t opening correctly at all. I get the following output whenever I execute the command and select a vm to open the file in:

/usr/bin/xdg-open: line 881: x-www-browser: command not found
(firefox:1055): Gdk-CRITICAL **: 02:29:08.017: gdk_atom_intern: assertion ‘atom_name != NULL’ failed
(firefox:1055): Gdk-CRITICAL **: 02:29:08.017: gdk_atom_intern: assertion ‘atom_name != NULL’ failed

Some files like images and pdfs work without any configuration, while kdbx and some txt files don’t open properly at all.

After a couple of tests it looks like this is an issue exclusive to fedora 34 (at least for me). Despite following Sven’s instructions to set the default application in its template VM, some files will still open in Firefox. Let me know if anyone else can confirm this behavior in their environment.

For me an easy fix was to simply use debian 10 instead of fedora 34. I have not tested to see if older versions of fedora exhibit the same issue.

One last question I have - Is there a way to block all stdout coming from the destination VM going to the src VM (from execution of qvm-open-in-(d)vm), maybe with RPC policies? I have an appVM named “secure-view” (similar to the default “vault” VM) that I’d like to use for read-only access to files in other VMs, with no network access of course.

after installing the printer Kyocera FS1370DN on 4.1rc4 on a fedora 34 template-clone, I get that:
(system-config-printer.py:21144): Gdk-CRITICAL **: 14:36:50.762: gdk_atom_intern: assertion ‘atom_name != NULL’ failed
(system-config-printer.py:21144): Gdk-CRITICAL **: 14:36:50.763: gdk_atom_intern: assertion ‘atom_name != NULL’ failed
thank you for any help to resolve it.

In Thunderbird each time I open a link I get a

[dom0] Operation Execution box with source:
email (Qube) asking me where to open the URL (qubes.OpenURL) and Target

but I forgot how I did that and I can’t seem to find anymore how I did this. I also wonder if I can set this option for files as well?

Maybe this can help: