Qvm-create-windows-qube 4.1 beta?

From elliotkillick/qvm-create-windows-qube

  1. Download the installation script by opening the link, right-clicking and then selecting “Save [Page] as…”
  2. Copy install.sh into Dom0 by running the following command in Dom0:
  • qvm-run -p --filter-escape-chars --no-color-output <name_of_qube_script_is_located_on> "cat '/home/user/Downloads/install.sh'" > install.sh
  • Make sure to get all the single and double quotes
  1. Review the code of install.sh to ensure its integrity
  • Safer with escape character filtering enabled in the prior step; qvm-run disables it by default when the output is a file
  1. Run chmod +x install.sh && ./install.sh
  • Note that this will install packages in the global default TemplateVM , which is fedora-XX by default

When I set the install.sh file as executable, step 4. I run the command in Dom0 and nothing happens.

Am I missing something?

The install file is in Dom0 Downloads, and I cd Downloads/ then run the command to no avail.

It’s like it’s not listening to me or something. Any ideas?

What exactly happens when you run ./install.sh? Does it not output anything? There’s a lot of echo statements in the script— perhaps it gets stuck after one of those echo, and you can see where the script hangs?

The script ends up creating a resources qube. Does it appear in your Qube Manager?

I’m also not sure if Qubes Windows Tools work in R4.1.

Nothing appears, and nothings appears to happen. When I run./install.sh it doesn’t do anything. I can see the install.sh script in dom0, but it doesn’t want to execute.

I just downloaded install.sh and ran sudo chmod +x install.sh, and then ran ./install.sh, and the script began running. I know you said you followed the steps above, but perhaps it’s worth double checking that the script content is there and that it’s executable?

Also, I tried running the qvm-run -p ... command above, and it did not work for me. I think the double quotes may be the issue; I’ve always used qvm-run as qvm-run -p <VM> 'cat ~/file.txt' > dom0/file.txt, i.e. with single quotes.

Are you on 4.1?

Yes, an .iso from the Qubes Open QA, so I don’t know which “version” or repos exactly.