QubesOS become undetectable after restarting it via start menu

EDit: I tried to using another USB stick and USB port and even though I had the same black screen after choosing reboot when installation was complete, this time my PC was able to detect qubesOS. I only notice that TOR network is significantly more unresponsive or extremely slow time to time compared to running it on my windows dekstop. Does anyone know if it is normal or my installation had some sort of problems?

I will keep it short. I had installed qubesOS successfully but when I hit restart from the start menu in Qubes, it does seem to restart then go to a black screen and freeze so I turn off the laptop then on then I discover my bios is not able to detect any detectable OS. I tried playing with legacy mode, UEIF mode, secure boot etc. nothing helped. I also tried installing qubes via legacy and UEIF.

One more thing. For my laptop to be able to detect qubesOS after installation I have to unplug the USB instead of pressing reboot because choosing reboot button also causes my bios to not be able to detect a bootable OS.

I have Dell 7490 i5 8350U 16gb 256ssd


  1. qubesOS installation only succeeds if USB is removed at the end instead choosing reboot option at the end of the successful installation screen.
  2. qubesOS installation succeeds but is not detectable to boot if I choose the reboot option at the end of the successful installation screen.